2011 MBA trackpad freezes when USB plugged in <-- android file transfer the culprit

Discussion in 'MacBook Air' started by thadoggfather, Sep 25, 2012.

  1. thadoggfather, Sep 25, 2012
    Last edited: Feb 26, 2013

    macrumors 68040

    thadoggfather

    Joined:
    Oct 1, 2007
    #1
    It only happens for a few seconds before I can use the trackpad again, but it's been doing it all the time. Anyone else?

    Think an SMC reset would help this?

    oh, and on 10.8.2.
     
  2. thread starter macrumors 68040

    thadoggfather

    Joined:
    Oct 1, 2007
    #2
    resetting NVRAM and PRAM fixed it

    :)
     
  3. macrumors regular

    Joined:
    May 11, 2012
    #3
    Awesome, that means I get to do this today, too. :p
     
  4. thread starter macrumors 68040

    thadoggfather

    Joined:
    Oct 1, 2007
    #4
    still doing it :/

    oh well. at least it only temporarily freezes and then comes right back.
     
  5. macrumors newbie

    Joined:
    May 15, 2011
    #5
    I have the same problem on my MBP 2010 only sometimes I never regain control of the trackpad and end up having to hard reset :/
     
  6. macrumors 6502a

    Joined:
    Apr 28, 2008
    #6
    Me too...

    Me too on 2009 13inch MBP running 10.8.2.

    It only started a couple months ago and I can't figure it out. I might try the PRAM and NVRAM reset just in case.
     
  7. macrumors 6502a

    Joined:
    Apr 28, 2008
    #7
    so resetting PRAM (NVRAM?) worked for me. Let's hope the fix sticks but at least I have a temporary fix. Thanks for the tip!
     
  8. macrumors regular

    Joined:
    May 11, 2012
    #8
    Odd question, but do you happen to have Android File Transfer installed? That's what the problem was for me, removing it fixed me right up. I saw the solution in another thread on here.
     
  9. macrumors 6502a

    Joined:
    Apr 28, 2008
    #9
    Actually yes I do. But I'm probably just going to have to deal with it then. I need android file transfer.
     
  10. macrumors 6502

    Joined:
    Aug 12, 2009
    #10
    happens on my MBP 2011. after a while, I get it back
     
  11. macrumors 6502a

    Joined:
    Oct 26, 2007
    Location:
    Sydney, Australia.
    #11
    Corrupt USB device. Ditch it.
     
  12. macrumors regular

    Joined:
    May 11, 2012
    #12
    Right. I'll just go ahead and discard my mouse, keyboard, cell phone, external hard drive, and ~12 separate flash drives.
     
  13. macrumors newbie

    Joined:
    Dec 5, 2007
    #13
    I know this thread is a few months old now, but in weeks of searching this is the ONLY mention of the exact problem I am having with my new (fall 2012) 15" retina display MBP.

    It happens when any USB device that mounts a drive is plugged in.

    Did anyone figure out the cause / find a solution?
     
  14. macrumors regular

    Joined:
    May 11, 2012
    #14
    Do you have Android File Transfer installed by chance?
     
  15. 3bs
    macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #15
    I do. Is it definitely causing it? Seems stupid because I never had this issue until I had a software update that specifically said it should fix something to do with USB devices but it actually started doing this. I'm on 10.8.2 on mid 2012 11" MBA.
     
  16. macrumors regular

    Joined:
    May 11, 2012
    #16
    AFT was causing the problem for me, and for several others in similar threads. I removed it and the problem went away. If you can manage without Android File Transfer, you can try removing it and see if your problem resolves.
     
  17. thread starter macrumors 68040

    thadoggfather

    Joined:
    Oct 1, 2007
    #17
    Thanks, just asked a friend who was having the same problem on a 2009 MBP on ML if removing 'Android File Transfer' fixed it for him (since he recently tried out a Nexus 7) and he said it worked.

    So I did the same on my machine and expect the same results.

    I never could isolate it because I tried out my first Android, the Galaxy Nexus, in the middle of last summer; same time as ML release.

    So I always attributed it to the OS, not some particular app or functionality.

    Thanks!

    I updated original post title so people don't have to sift through this read for a quick solution.
     
  18. thread starter macrumors 68040

    thadoggfather

    Joined:
    Oct 1, 2007
    #18
    Hmmm, it still seems to be doing it even after AppZapping android file transfer.
     
  19. macrumors newbie

    Joined:
    Mar 3, 2013
    #19
    I've been suffering from this issue for a while already and it seems this is the only thread I could ever found that talks about it. Yes I've been using ATF and yes I've removed it. While it seems to have solved the issue most of the time, the freezes still comes back sporadically when I plug in an USB device. Not sure what else I can do to make it go away totally :confused:
     
  20. macrumors regular

    Joined:
    Jul 28, 2011
    #20
    though the thread is quite old: i just removed the android-thingy from the startup objects and now it works. thanks for the help.
     
  21. macrumors newbie

    Joined:
    Mar 8, 2014
    #21
    It's not Android

    Well I don't know about you guys but I have an iPhone with no Android do no need or Android File transfer. It's stalling whenever I plug in a USB device to my MBP

    It's longer than 3 seconds maybe about 10, then when it clears it will come back randomly.

    I have a 15" MBP 2.6GHz
    8GB Ram
    OS X Lion 10.7

    Thanks DJ153
     

Share This Page