2012 imac firmware update 2.0 is up.

Discussion in 'iMac' started by xgman, Dec 17, 2012.

  1. macrumors 68040

    xgman

    Joined:
    Aug 6, 2007
    #1
    2012 imac firmware update 2.0 is out.


    iMac EFI Firmware Update is recommended for all iMac (late 2012) models. This update contains general performance fixes pertaining to sleep and Thunderbolt, and improves compatibility when using the 5GHz band in Wi-Fi. Boot ROM or SMC Version Information: After Update is complete:

    Build version: 010A.05

    ROM version: IM131.88Z.010A.B05.1211151146
     
  2. macrumors regular

    Joined:
    Jun 22, 2012
    Location:
    USA
    #2
    Where do you see it? Normal Software Update from finder? I just tried and it says no updated available.
     
  3. thread starter macrumors 68040

    xgman

    Joined:
    Aug 6, 2007
    #3
  4. thread starter macrumors 68040

    xgman

    Joined:
    Aug 6, 2007
    #4
    hmmm . . said not supported on my 2012 27" imac. I wonder what this is exactly?
     
  5. macrumors 68000

    jetjaguar

    Joined:
    Apr 6, 2009
    Location:
    somewhere
    #5
    not available for my imac either
     
  6. macrumors 65816

    Photography

    Joined:
    Apr 10, 2007
    #6
  7. macrumors member

    Joined:
    Nov 23, 2012
    #7
    Downloaded and try to install still get message said not support for my iMac.:confused:
     
  8. macrumors member

    Joined:
    Sep 3, 2007
    #8
    I got the same thing too, but have 10.8.3 beta installed. Are you still on 10.8.2?
     
  9. Hasn'tbeensober, Dec 17, 2012
    Last edited: Dec 17, 2012

    macrumors member

    Joined:
    Nov 23, 2012
    #9
    I think so, what ever come with the late 2012 iMac.
    yes just check and it is 10.8.2
     
  10. macrumors member

    Joined:
    May 6, 2003
    Location:
    Maine, USA
    #10
    Spent about half an hour with Apple support after both of today's updates failed on my 27", 2012 iMac, telling me that neither was supported by the machine. They were surprised at the updates not working and downloaded info from my machine to forward on to engineering. We're scheduled to talk again on Wednesday to see what they've found out about this problem. I told them that there were others besides me experiencing this issue.

    Any rhyme or reason we can figure out here? Anyone with a 27 incher that had either or both of today's updates work?
     
  11. macrumors member

    EPiCDiNGO

    Joined:
    Sep 10, 2012
    #11
    I am so upset right now about these updates not working on the 2012 iMacs :(
     
  12. MSL
    macrumors member

    Joined:
    Sep 6, 2008
    Location:
    Brighton, UK
    #12
    The updates also fail on my new 'late' 27" iMac.
     
  13. macrumors 6502a

    Joined:
    Nov 10, 2012
    #13
    Worked for me.

    Maxed out 21.5" 2012.

    Edit: It also shows up in the Mac App Store for me.
     

    Attached Files:

  14. macrumors member

    Joined:
    Nov 23, 2012
    #14
    Maybe just for 21.5 model only??
    Any through??:confused:
     
  15. thread starter macrumors 68040

    xgman

    Joined:
    Aug 6, 2007
    #15
    I guess it is 21.5" only, but . . .

    "About iMac EFI Update 2.0

    This update is recommended for all iMac (late 2012) models."

    Key word: "ALL"??
     
  16. hfg
    macrumors 68030

    hfg

    Joined:
    Dec 1, 2006
    Location:
    Cedar Rapids, IA. USA
    #16
    The link says it only applies to the Late 2012 21.5" iMac.


    About iMac EFI Update 2.0
    This update is recommended for the iMac (21.5-inch, Late 2012).
     
  17. macrumors 65816

    Photography

    Joined:
    Apr 10, 2007
    #17
    Directly from the page: This update is recommended for all iMac (late 2012) models.
     
  18. macrumors member

    Joined:
    May 6, 2003
    Location:
    Maine, USA
    #18
    Ah ha, they've updated the page to specify 21.5" machines only. This said "all late 2012 iMacs" yesterday when the update was first released.
     
  19. hfg
    macrumors 68030

    hfg

    Joined:
    Dec 1, 2006
    Location:
    Cedar Rapids, IA. USA
    #19
    In fact, they updated it in the last 2 hours .... just since I made the post above which was cut/past from the page at that time.

    But, I still am not seeing it in Software Update for my 27"... yet.

    If I download it from the link (just now) it won't run as it is "unsupported on this machine".
     
  20. macrumors member

    Joined:
    May 6, 2003
    Location:
    Maine, USA
    #20

    My guess is that the firmware update isn't needed on the 27" models (since they were manufactured a little later than the 21"ers) OR they realized they need a modified update for the 27" machines and are working on one.
     
  21. thread starter macrumors 68040

    xgman

    Joined:
    Aug 6, 2007
    #21

    Huh ???? It still says "ALL" today. http://support.apple.com/kb/DL1618

    iMac EFI Update 2.0
    Download icon
    About iMac EFI Update 2.0

    This update is recommended for all iMac (late 2012) models. This update contains general performance fixes pertaining to sleep and Thunderbolt, and improves compatibility when using the 5GHz band in Wi-Fi.
    Boot ROM or SMC Version Information: After Update is complete:

    Build version: 010A.05
    ROM version: IM131.88Z.010A.B05.1211151146
     
  22. macrumors member

    Joined:
    May 6, 2003
    Location:
    Maine, USA
    #22
    How weird that this keeps changing!

    On the main downloads page: http://support.apple.com/downloads/

    It still says:

    iMac EFI Update 2.0
    This update is recommended for the iMac (21.5-inch, Late 2012)
    Dec 17, 2012 - 4.32 MB
     
  23. thread starter macrumors 68040

    xgman

    Joined:
    Aug 6, 2007
    #23
    Until you click on it.
     
  24. macrumors member

    Joined:
    May 6, 2003
    Location:
    Maine, USA
    #24

    Yeah, that's what I meant - the link says one thing, the page itself has been changed again, to say something else.
     
  25. macrumors newbie

    Joined:
    Jan 28, 2013
    #25
    IMac 21.5" with Fusión drive not supprted either

    I just checked the iMac EFI firmware update 2.0 on my iMac 21.5" equipped with fusion drive and the installer declares it as "unsupported". Would be nice to know why Apple did not include this information in their release.
     

Share This Page