2013 13" MBA Sleep Issue

Discussion in 'MacBook Air' started by heeshung, Jun 27, 2013.

  1. heeshung, Jun 27, 2013
    Last edited: Jun 27, 2013

    macrumors newbie

    Jun 27, 2013
    I recently bought a new 13" MBA with the i5 and 4GB RAM less than a week ago. I've been noticing a sleep issue that I believe is software-related. I talked to AppleCare and they agreed that it was probably a software issue. But since it is software-related, that should mean that the issue can be reproduced on any MBA with the same hardware, and I was wondering if anyone else has had the same problem or can reproduce it.

    I have tried resetting SMC, but it doesn't help.

    I am running 10.8.4 ML. If you're running the same version, here's how to induce this issue:

    1. Go to Energy Saver in your System Preferences.
    2. In the Battery section, change your Display Sleep timer to the minimum (1 min) and make sure "Put the hard disk to sleep when possible" is CHECKED.
    3. Take your MBA off of the charger if it isn't already.
    4. Idle at the desktop; your display should dim, then sleep in about a minute.
    5. When the display goes completely dark, wait around 25 seconds.
    6. Wake up your MBA with the keyboard, then log in if you have to and use your computer normally.
    7. If the issue can be reproduced, your MBA will go into hardware sleep within ~30 seconds.

    Now repeat the steps with the hard disk checkbox UNCHECKED.

    Here's my complete shot-in-the-dark hypothesis: The checkbox enables the MBA to put the hardware to sleep very soon after the display sleeps (e.g. the same sleep as if you closed the lid). So it activates a timer when the display sleeps, and as the timer reaches zero, it commands the hardware to go into sleep mode. However, when you wake the display up after it sleeps, the timer somehow isn't cancelled and continues to induce hardware sleep when it hits zero.

    If anyone running 10.8.4 with the same hardware can try this out, I'd be forever grateful.

    Thanks in advance.
  2. macrumors 6502

    Oct 23, 2011
    Miami, FL
    Never really thought about it, but now that you mentioned I realized that it happened and happens to me pretty often.
    Both my old 2011 i5 4gb 128 MBA and my new 2013 i7 8gb 256 MBA have that problem. Might be a ML issue.
  3. thread starter macrumors newbie

    Jun 27, 2013
    Resetting the NVRAM seemed to fix the issue for now; I'll update if it recurs.
  4. macrumors regular

    Apr 15, 2013
    Houston, TX
  5. macrumors newbie

    May 5, 2012
    I have experienced this exact same issue twice now. Goes back to sleep state probably about 15-20 seconds after having been woken from sleep.
  6. macrumors 6502


    Apr 8, 2006
  7. macrumors newbie

    Jun 29, 2013
    Yes, it happens to me all the time

    Hi - this happens to me all the time on my MBA 2010 - 13", 4GB/256GB. Its been happening ever since the last software update. How do we get Apple to address this? Its very annoying.
  8. macrumors newbie

    Aug 8, 2013
    happens to me all the time with my new macbook air 2013

    Is there a fix to prevent this issue ?

Share This Page