24" iMac won't get IP address from Netgear router

Discussion in 'iMac' started by ascender, Oct 20, 2006.

  1. ascender macrumors 68000

    Joined:
    Dec 8, 2005
    #1
    I've had my 24" iMac working this morning on my Netgear router, but it now refuses to get an IP address and just keeps getting the default one of 169.something instead of one from the DHCP pool.

    This is a new iMac, everything has been updated and the wireless card has previously worked today in both OS X and Windows via boot camp.

    I have an iBook and a Windows laptop also on the connection currently, so I'm a bit confused as to what has happened. I've found a thread from before on here and have checked the obvious things, but no joy.

    I've manually assigned the Mac an IP address, but when I ping the router, it says "host is down", which it clearly isn't.

    Any ideas? This is driving me mad.....

    Thanks,


    Mike.
     
  2. rogersmj macrumors 68020

    rogersmj

    Joined:
    Sep 10, 2006
    Location:
    Indianapolis, IN
    #2
    I frequently had this problem when I used to use Netgear routers, which is one of the reasons I and my roommates back then gave them up. Have you tried resetting the router? Every Netgear router I've used eventually becomes flaky on the wireless. I bought a bunch of them because they were so cheap -- 4 for myself for use at home and at relatives' houses, 1 for my fiance, 1 for another friend -- and all of them have had to be replaced, every single one, because their wireless stopped working and stopped handing out IPs just as you are describing (except for one, which just completely bricked itself).

    I'm not necessarily saying that is your problem, but if you're connected to the SSID and can't get an IP then that's something to be aware of with these Netgears. So I would just try rebooting the router first. Are you using any sort of encryption or MAC address filtering?
     
  3. ksz macrumors 68000

    Joined:
    Oct 28, 2003
    Location:
    San Jose, CA
    #3
    Unfortunately, I have also had the same problems with Netgear, even on Windows. My laptop would time out while attempting to acquire an IP address. After several calls to Tech Support and upgrades to new firmware, the problem persisted. Since routers are so cheap, I simply went out and purchased a US Robotics model and there have been no problems since.
     
  4. ascender thread starter macrumors 68000

    Joined:
    Dec 8, 2005
    #4
    Its weird, because my iBook has been working with the router faultlessley for a couple of years. I managed to get connected earlier but its since gone again.

    I'll call Apple, even though I don't hold out much hope. I'd really like to avoid buying a new router just because of this.

    I have WEP turned on just now, but no MAC address security. I've also tried rebooting the router.
     
  5. mongoos150 macrumors 6502a

    mongoos150

    Joined:
    Sep 20, 2005
    #5
    Strange, I've never had a problem with Netgear - MUCH more reliable than craptacular Linksys. Which router do you have? The new WPN824 is a pretty amazing router, insane transfer speeds. Sorry to hear about your router. Try power cycling everything and reentering your settings on both setups. I've also heard of people turning off the obscure options in the webpage router setup, try playing with those settings.
     
  6. ksz macrumors 68000

    Joined:
    Oct 28, 2003
    Location:
    San Jose, CA
    #6
    I think my problems with the old Netgear router started when I installed one of the AOL clients, which in turn installed PortMagic. Up to that time the router and laptop had been getting along just fine. I'm not sure if AOL or PortMagic was to blame, but since I could not fix the problem by uninstalling either of them (and Netgear Tech Support couldn't solve it either), I decided to replace the router and my problems went away.
     
  7. rogersmj macrumors 68020

    rogersmj

    Joined:
    Sep 10, 2006
    Location:
    Indianapolis, IN
    #7
    Well I was unable to pinpoint what caused my Netgears to fail. They were MR814s and WGR614s. None of us used AOL or had any sort of ISP software installed -- just a broadband modem straight to the router straight to Windows XP machines. The worst of them died after less than 8 months, the longest one lasted about 1.5 years. But they all failed, beginning with the symptoms the OP is reporting. They were well-ventilated (nothing stacked on them), protected by good surge protectors...there was no reason for them to fail. But myself and my friends who went through all the hassle of dealing with those damn things will never buy Netgear again.

    My very first router was a Linksys B wireless router, that's like 4 years old now. That thing still works, although I use newer Linksys routers now. Two of my three Linksys routers are well over a year old and still going strong. I keep a couple of the Netgears around to use a dumb switches -- they work fine for that.

    Obviously I haven't had an exactly typical experience, but if you look at consumer reviews around the net you do see higher failure rates on Netgear routers than on Linksys ones.
     
  8. ascender thread starter macrumors 68000

    Joined:
    Dec 8, 2005
    #8
    Well, it looks like this is a major problem and has been introduced by 10.4.8. Over on the Apple Support Forums there's lots of people having similar problems, regardless of what router they have. Crux of it seems to be that when you update your Airport settings, the Mac doesn't update the preferences, so then just reassigns the default IP address.

    At the moment mine is working, but after a reboot I have to manually select the network.

    For other people they've had to disable G on their router and go with B, WPA encryption also seems to be an issue for some.

    Amazing to think this has slipped by the testers of 10.4.8.
     
  9. rfrankl macrumors 6502

    Joined:
    Apr 15, 2006
    #9
    I have the WPN824 also, and have never had a problem. I get great range and speeds with it back when I was on Windows and with my new iMac.
     

Share This Page