5.1 sound in VLC hijacks computer

Discussion in 'Digital Audio' started by uplusd, Nov 12, 2008.

  1. macrumors 6502

    Joined:
    Apr 8, 2008
    Location:
    Silicon Valley
    #1
    Hi,

    I'm having a problem that occurs on both my iMac and MBP, so I know it isn't computer specific. When I'm watching something encoded in 5.1 in VLC, I change the output in the Audio menu (Audio -> Auto Device -> Encoded Output). Whenever I quit out of VLC, none of the system sounds work anymore. That means iChat, Mail, Youtube in Safari, emptying trash sound, etc. I can't get these sounds to come back until I restart the computer. Does anyone know how to solve this issue or is it just something we have to live with for 5.1 encoded output?
     
  2. macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #2
    wow, that is odd... i havent experienced this problem. what is the format of the audio?
     
  3. macrumors 68030

    Big-TDI-Guy

    Joined:
    Jan 11, 2007
    #3
    Tis a bit of a bug with VLC. MPlayer does it too sometimes after exiting.

    Just go to applications / utilities / Audio MIDI Setup

    Prperties For: Built-In Output
    Default Output: Built-In Output
    System Output: Built-In Output

    Under Audio Output: Source - Digital Out - Format 44100.0Hz - change 2nd drop box from from "Encoded Digital Audio" over to 2ch-16bit or what have you.

    Make a shortcut to audio midi setup on your dock, so if you happen to watch a lot of 5.1 videos - you can fix things in a jif.

    FYI, the system audio will be hijacked until you close the media player (under normal conditions) so if the movie stopped, and you leave VLC running, you have no system sounds until you exit VLC.

    Sucks at first, but I got used to it.

    What you "should" see after closing VLC / Mplayer.
     

    Attached Files:

  4. thread starter macrumors 6502

    Joined:
    Apr 8, 2008
    Location:
    Silicon Valley
    #4
    Hi,

    Thanks for the response. I changed the audio back from 24-bit to 16-bit, however the sounds are still gone.
     
  5. macrumors 68030

    Big-TDI-Guy

    Joined:
    Jan 11, 2007
    #5
    Did you quit VLC - or just "X" it out?

    If VLC crashed - you might have to force-quit VLC before it changes.

    That usually does the trick for me.

    What decoder / receiver are you using? Maybe that is hung up? Try toggling inputs on the receiver / decoder - see if that wakes anything up. Ones in a great while, my Z-5500s need a quick input toggle to get it listening again.
     
  6. thread starter macrumors 6502

    Joined:
    Apr 8, 2008
    Location:
    Silicon Valley
    #6
    Hey,

    I'm using the Z-5500 as well. Funny thing is that iTunes and other apps have sounds. It is only the system sounds and Safari that don't come back.
     
  7. macrumors newbie

    Joined:
    Jul 14, 2011
    #7
    I am having the exact same problem. The problem persists through VLC v1.1.10.1. If I enable SPDIF encoded output, VLC takes over sound and no other app sounds work until I restart the computer.

    Restarting coreaudiod does nothing. MIDI setup is toggling properly on its own when VLC quits properly. Manually toggling MIDI output setup does nothing. Manually toggling inputs on my receiver also does nothing. Only a full system restart restores sound. Sound in all apps works just fine until VLC encoded output is selected again. I can replicate the problem consistently.

    Does anyone know of any other way, any other process for resetting the sound driver/process etc. that doesn't require a full system restart?
     
  8. ckeilah, Jul 24, 2011
    Last edited: Jul 25, 2011

    macrumors newbie

    Joined:
    May 13, 2009
    #8
    This looks like some kind of BS sync problem. If I click on the "level" button on the Logitech control box then audio starts playing, but ONLY while the Subwoofer (or whatever) channel is being modified.
    I have power cycled the Logitech speaker system to no avail. I have ForceQuit coreaudiod. Mucked around with Audio Midi Setup, etc. etc. The only thing that might work is a full reboot. This is ********.

    EDIT: SOLUTION FOUND!

    Ok, so I figured out that the Logitech decoder was somehow just failing to sync with data that was obviously still being sent out by the Mac. So, I pulled the optical plug out of the Mac. After some HORRIBLE LOUD screeching (probably Mac trying to send a raw audio stream directly to the internal speakers, at least that's what it sounded like ;-) audio was restored! Only to the internal speakers, but at least it was audio. Hrmmmm, I thought... Here is what I *think* solved the problem:

    Unplug the optical out from the Mac. Power off the Logitech audio system (unplug it completely). Put the Mac to sleep. Plug in the optical out, plug in and turn on the Logitech sound system, un-sleep the Mac.

    While I was at all of the above, I also used the Audio Midi Setup to configure the main sound output to 96kHz/24-bit, and the Logitech now shows 96-24 on its screen when just playing normal Mac sounds. My ears aren't good enough to tell if there is any difference.

    I hope that helps.
     
  9. macrumors 68030

    Big-TDI-Guy

    Joined:
    Jan 11, 2007
    #9
    I would strongly, strongly, strongly advise you not continue with that fix.

    The combo ports on Macs are NOT very robust, and most are soldered directly to the motherboard. Having seen a few of these ports die, I'd avoid plugging / unplugging like the plague.

    Headphones tend to be less of an issue, but the shape / profile of the TOSLINK plug tends to hang up and damage the switch within the jack. Net result is a computer that cannot tell when headphones or optical plug is inserted - and audio continues to play over internal speakers all the time.

    If Apple used the same approach they did with iPods - I'd say have at it. Where the I/O connectors are floating and separate from the motherboard, you'd only have to replace the connector itself. But where that isn't the case - I'd use caution.
     

Share This Page