_NSAutoreleaseNoPool() compile error when adding MessageUI.framework

Discussion in 'iOS Programming' started by roeik, Nov 17, 2009.

  1. roeik
    Expand Collapse
    macrumors member

    Joined:
    Dec 25, 2008
    #1
    When I add the MessageUI framework I am getting the following error on the debugger:

    I only get the error when I am compiling on the device. When you compile on the simulator it doesn't appear. Any idea why?

    Thanks.
     
  2. ghayenga
    Expand Collapse
    macrumors regular

    Joined:
    Jun 18, 2008
    #2
    I'm fairly sure the file above doesn't exist on the iPhone at that path. Perhaps you linked the framework in as an absolute path by mistake?
     
  3. jnic
    Expand Collapse
    macrumors 6502a

    Joined:
    Oct 24, 2008
    Location:
    Cambridge
    #3
    Those aren't errors, they're warnings. You're leaking memory. Post code or run it through a static analysis tool or Leaks.

    That's being caused by your iPhone being Jailbroken, not by your code. Nothing to worry about.
     
  4. PhoneyDeveloper
    Expand Collapse
    macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #4
    Are you trying to load the mail UI from a background thread? Don't do that.
     
  5. roeik
    Expand Collapse
    thread starter macrumors member

    Joined:
    Dec 25, 2008
    #5
    Yes, sorry. I meant warnings!


    I added it using the menu on xcode (right click on frameworks folder->Add -> existing framework), so I am not sure if I it is using absolute link or now.

    And I don't think the problem is with my code. It gives me this error just when you I add the framework (when I delete the framework the warnings disappear).
     

Share This Page