A couple peculiar ipod glitches

Discussion in 'Macintosh Computers' started by absurdio, Apr 8, 2004.

  1. absurdio macrumors 6502

    Joined:
    Aug 25, 2003
    Location:
    RI, Chi, and/or NY.
    #1
    I've run across a couple of little oddities with my ipod which, if they were isolated occurances, I would just ignore. However, they've started slowly adding up...and so I thought I'd turn, as always, to my trusted friend, the internet. =)

    Oddity 1: There are a couple of songs that I've found that don't play. One is a Casualties song from a mix cd I made long ago, and the other is a Postal Service song that I got from the iTunes music store. Both songs play perfectly fine in my iTunes library. On my iPod, though, both songs have the same problem...and don't play. They appear, as they should, in the menus under the lists of their respective artists...and you can select them...and, indeed, when you do, it LOOKS like it's going to start playing (that is, it goes to the screen with the song title, band name, elapsed time, etc...) but then, instead of starting, it goes immediately back to the main menu (Playlists, Browse, Extras...). No idea why. They don't start playing and then stop...they just don't start...and I don't know why. Same problem for both songs, and both are 128kbps aac...just like almost all of my iTunes library.

    Oddity 2: One band appears twice on my list of Artists in my iPod. And right after itself on the list...so my list reads "Beat Happening, Beatsteaks, Beatsteaks, Belle & Sebastian," and again, I can't explain why. The two headings are spelled identically and have identical album and song contents. I checked my iTunes library, and I definitely only have one folder called "Beatsteaks" and only one copy of each song. This isn't a HUGE problem, but it is a nuisance. And annoying as hell. All the songs play fine in both listings, but there just shouldn't BE two listings.

    Both of these problems exist even right after I update my ipod. I have no clue what's going on. Anyone else run into this? Anything I can do? Is there a way to delete the songs/headings from my ipod and then try re-updating it? As always, thanks, everyone.

    -nb
     
  2. mrgreen4242 macrumors 601

    mrgreen4242

    Joined:
    Feb 10, 2004
    #2
    Dunno about problem one, but check out the artist name in the song info, there might be a space after one of them, which makes it come up twice. I've had that happen a few times.

    Rob
     
  3. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #3
    Another possibility is that for some reason, one of the songs has a different genre than the other. I've noticed some funny business regarding genres on the iPod. Sometimes different CDs are coded in gracenote differently. I had two Shonen Knife CDs and I couldn't find one because it was in the wrong genre.

    For the other problem, that's really interesting. Are they files off a CD? If so, is it worth it to try ripping them in another format, such as MP3? I can't say I've had this problem, but I think there are an awful lot of playcount=0 songs on my iPod. ;)
     
  4. Inspector Lee macrumors 6502a

    Inspector Lee

    Joined:
    Jan 24, 2004
    Location:
    East Lansing, MI
    #4
    re: problem #2

    Sounds like you definitely have some extra spaces at the end of the artist name. I had this occur for several artists scattered throughout my library and couldn't figure out how they got there. Being a details man, I finally had to clean house.

    To get rid of them, sort your library by artist and select the first line. Click "Get Info" and highlight the artist name. If the highlighted area is greater than the artist name, you have extra space(s) at the end of the name. If the number of spaces differ, you will get multiple occurrences of, in essence, the same artist in your libray. So once you highlight the artist, choose "Next" and see if any others have the extra space(s).

    Getting rid of these extra spaces can be frustrating. For one thing, you cannot simply backspace. You need to either clear and retype the name(s) or select only the extra space and delete it.

    I believe this will solve half of your problems. One can tell if there are extra spaces for an artist by the presence of ellipses "..." at the end of an artist name on the iPod and also the format is left justified and not centered across the screen.
     
  5. absurdio thread starter macrumors 6502

    Joined:
    Aug 25, 2003
    Location:
    RI, Chi, and/or NY.
    #5
    You guys got it right. I was so hung up on making sure the spellings were the same, I didn't actually check to see if there were any extra spaces or anything. So i just highlighted all of the song with "beatsteaks" somewhere in the artist/title line and got the info for all of them. Sure enough, the band name was blank, suggesting that there had been two different names. So i typed in a single name, updated everything, and now that's as it should be. Thanks again.

    ...Now on to problem number 1 =)
     
  6. mmmdreg macrumors 65816

    mmmdreg

    Joined:
    Apr 14, 2002
    Location:
    Sydney, Australia
    #6
    i got a few probs too.. every now and then, while playing through a song, partway through, it'll just skip the rest of the song and go to the next..

    and secondly, I got Nirvana's Nevermind.. the iPod lists "Nevermind" and "Never Mind" as two seperate albums, both with exactly the same songs in it. iTunes has only one copy listed under "Nevermind".. and yeah. if you go to "All" the songs for Nirvana on the iPod, only one set of songs comes up also...
     
  7. absurdio thread starter macrumors 6502

    Joined:
    Aug 25, 2003
    Location:
    RI, Chi, and/or NY.
    #7
    Well, still no solution, but another song to add to the list.
    This is a Rancid song from their new album. It plays fine in iTunes, it plays fine from the cd, nothing SEEMS suspect...except that in my iPod, it doesn't play. Same problem. It skips over that song and goes to the next one. Even if you select that song, it just goes to the next one.

    Is there a way I can delete that from my ipod and re-update and hope it works this time?
     
  8. g30ffr3y macrumors 6502a

    g30ffr3y

    Joined:
    Jul 18, 2002
    Location:
    buffalo ny
    #8

    maybe your ipod is excersizing civil disobedience against your poor choice in music???
     
  9. absurdio thread starter macrumors 6502

    Joined:
    Aug 25, 2003
    Location:
    RI, Chi, and/or NY.
    #9
    Hah. Yeah, I wouldn't blame it, either. But it'd damn well better boycott the rest of the filthy album, too.
     
  10. Mord macrumors G4

    Mord

    Joined:
    Aug 24, 2003
    Location:
    UK
    #10
    yhea i get that to i got five different dusty springfeild's all spelt the same way
     
  11. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #11
    I've got some songs that seem to do this consistently on the first try, and then play correctly the second time. Maybe my songs are considered borderline tasteless? :)
     
  12. bondipete macrumors member

    Joined:
    Jan 16, 2003
    Location:
    Melbourne, Australia
    #12
    Hmm.
    I have had a similar-ish problem. When I plug in my iPod and it syncs, I get told that "Songs including 'Song Title' can't be copied to the iPod". But they once were on my iPod.
    I suspect it's something to do with the glitchy new update
    http://forums.macrumors.com/showthread.php?t=69826&highlight=ipod+update
    and I thus wonder: did you install either the iPod update or iTunes 4.5?
    Because both seem to be causing problems.

    Very mysterious.
     
  13. absurdio thread starter macrumors 6502

    Joined:
    Aug 25, 2003
    Location:
    RI, Chi, and/or NY.
    #13
    I've found that some of my little iPod problems can be dealt with by openning iPod options, switching to "Manually manage songs and playlists," and then deleting the troublesome song or songs. Then I just switch it back to automatically updating, and it adds those files again...and ususally works. Hope that helps.
    -nb
     
  14. ShaggyLR macrumors member

    Joined:
    Jan 12, 2004
    Location:
    Montreal
    #14
    B&S YES!

    Although this is of no help to you, I would just like to say "right one!" for having Belle & Sebastian on your iPod!!
     
  15. absurdio thread starter macrumors 6502

    Joined:
    Aug 25, 2003
    Location:
    RI, Chi, and/or NY.
    #15
    *smile* Maybe the Belle & Sebastian even compensates for my owning Rancid's Indestructable (which prompted the above comment)
     
  16. virividox macrumors 601

    virividox

    Joined:
    Aug 19, 2003
    Location:
    Manila - Nottingham - Philadelphia - Santa Barbar
    #16
    you could try restting ur ipod

    or reformating it and reloading the entire library that shouldnt take more than 30 minutes anyway
     
  17. bennetsaysargh macrumors 68020

    bennetsaysargh

    Joined:
    Jan 20, 2003
    Location:
    New York
    #17
    the same thing happens to me sometimes.
    i record something with my italk, and it wont play the voice memo. could it be the same problem?
     

Share This Page