A little help please.

Discussion in 'Mac Programming' started by cdsboy, Dec 12, 2006.

  1. macrumors newbie

    Joined:
    Jul 8, 2006
    #1
    So i am trying to compile this program. It is based on allegro, uses jpgalleg, dumb, and ogg vorbis for support. and when i try to compile it it fails with the error "Command /Developer/Private/jam failed with exit code 1".

    heres what the build results prints.
    Anyone know whats going wrong or have any ideas? Btw my xcode is the latest version, i downloaded the newest version last night.
     
  2. Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    #2
  3. thread starter macrumors newbie

    Joined:
    Jul 8, 2006
    #3
    is that compatible with xcode? I would like to continue using xcode.
     
  4. macrumors regular

    Joined:
    Mar 5, 2006
    #4
    Upgrade your project's targets to native targets by choosing Project > Upgrade All Targets in Project to Native. By doing this, Xcode uses its native build system instead of jam to build the project. Jam is the old build system used by Project Builder, Xcode's predecessor.

    Looking at the build log, you're getting a link error because the variables hotlineRows and optionsScoringNames have been defined multiple times. A common cause of multiple symbol definition errors is including a header file more than once.
     
  5. thread starter macrumors newbie

    Joined:
    Jul 8, 2006
    #5
    ok i upgraded all the targets. Now it is compiling. But it still does not work. Now its saying it is either damaged or incomplete.
     

Share This Page