1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

A word of caution regarding Lion's Recovery partition

Discussion in 'Mac OS X 10.7 Lion' started by CristobalHuet, Jul 24, 2011.

  1. CristobalHuet, Jul 24, 2011
    Last edited: Jul 24, 2011

    macrumors 65816


    Just wanted to share my experience attempting to partition/erase my MBA's SSD via the recovery system (command-R at the boot up chime).

    What I basically wanted to do was erase the partitions (2) that I had on the SSD, and replace them with one new, empty partition. Logically, I went over to the SSD in the sidebar from the recovery's Disk Utility, then "Partition", and from the drop down menu, "1 partition".

    So, what followed next was basically the recovery being unable to unmount the 2 partitions. I tried *everything* to unmount/get them to unmount, starting with erasing their contents, and attempting to restore the image of my external clone onto the SSD via the "Restore" tab.

    I tried to repair the disk(s), different filesystems, alll for nothing. I couldn't repartition the drive, period.

    What ended up happening was that I booted into my cloned external drive, launched up Disk Utility from there, and went about erasing and repartitioning the SSD as one, new partition. It worked, flawlessly (and thankfully, I was out of ideas of how to proceed next, really was getting worried there was a hardware issue with the drive).

    All that just to say that if you're unable to partition your internal hard drive via the recovery partition (which, goes without saying, resides on the same partition as your startup system), then try giving Carbon Copy Cloner or SuperDuper! a spin, booting from the cloned drive, and running Disk Utility from there.

    Naturally, the next step was to reinstall OS X onto the empty partition. I had to manually copy over the DMG from my other Mac (seeing as the recovery partition was gone at that point), and load it up from the external. From there, the installation took over and continued as it should after a restart.

    Solved my issue. Hope you don't run into it, but if you do, that's my two cents. :)

    EDIT: Seems like single-user mode could've helped me out in this situation.
  2. macrumors 6502a


    You also can use a regular linux live disc to erase or change your partition table with for example gparted.
  3. macrumors newbie

    Maybe that didn't work because deleting the whole disc would include the recovery partition which you were booting from...you can't expect it to unmount and delete itself. ;)
  4. macrumors 65816


    Yep, just didn't want to go through the hassle of getting that set up.

    Doh. :D

    This is a good point, although it's worth noting that the recovery partition is in a separate section of the sidebar in Disk Utility. I was trying to combine the two internal partitions (none of which contained the recovery) into a single one. In other words, I wasn't touching the recovery partition in itself, just the other two.

    I like the idea of a recovery partition, but if this is one of the limitations and we're required to boot from another HD or disc to tinker with our internal disk's partitions, then damn. That'll be a pain, and it's sort of counterintuitive. What good is Disk Utility if it can't perform its main function, that is, partitioning, erasing, and restoring the disk?
  5. macrumors newbie

    True! First thing I did was burning a Lion DVD for doing the clean install...
    Maybe that Recovery Partition is for Average-Joe who never does a clean install but only reinstalls Lion over an existing installation or repair disc permissions when it comes to the crunch...I don't know.
    With this new Lion distribution strategy Apple doesn't seem to consider it necessary doing a clean install...
  6. macrumors 68020

    Sadly you were using Disk Utility wrong. Instead of listing a new general partition map for the entire disk what you should have done to achieve your goal is boot up into the Recovery partition. Load Disk Utility. Click on Partition in the right hand pane. Then, rather than use the drop down to select one partition overall, you should have selected one of the partition and then clicked on the minus sign. That would effectively remove it. Then you drag the remaining partition listed so as to fill it up with the remaining free space and hit apply. Disk Utility will then delete one of the partitions and add all the free space to the remaining partition. But you still want that partition deleted. So after you removed the two partitions you click on the erase tab on the right hand pane and erase the partition that you just resized. You are now left with one blank partition and the hidden Recovery partition.
  7. macrumors 65816


    This is what I attempted to do before selecting from the Dropdown menu, forgot to include it in my story.

    Same error - no dice. Disk Utility couldn't "unmount" any of the partitions to do its magic.
  8. macrumors 6502a


    This is exactly his problem. I noticed the same thing.

    What you have to do is select the existing partitions on the sidebar. Not the disk.

    You could have saved yourself a lot of trouble!

    *edit* I forgot to mention that I have actually done this on two separate MacBooks, and it worked each time. I deleted the existing partitions and created one new one using the Disk Utility on the recovery partition.
  9. macrumors newbie

    Got into this same problem. Not sure people actually get what "CristobalHuet" says. Nothing of the above solved my issue as well and boy I tried everything.

    What did work for me was booting with my original Snow Leopard install image usb that came wih my MBA, then going to disk utility from there.
  10. macrumors member

    You can create a Lion USB installer (follow one of the tutorials about creating a Lion USB installer, it involves extracting InstallESD.dmg from installer and restoring it to an USB).

    If you boot from this Lion USB you will be able the reparation you SSD.

    Believe me I had the same problem ;)
  11. macrumors newbie

    That will work too. The trick is running the Disk Utility to fix the issue with the partitions from a bootable USB/DVD/other machine when this error happens not form the Lion`s Recovery thing.

Share This Page