Able to restore four finger trackpad gestures on Rev A after 10.5.8 update?

Discussion in 'MacBook Air' started by dborja, Aug 6, 2009.

  1. macrumors 6502a

    Joined:
    Sep 13, 2007
    Location:
    Northern California
    #1
    I've lost the four finger trackpad gestures after the update, as expected. So, I checked the Extensions directory and found the AppleUSBMultitouch.kext file is still the "hacked" one. I still went through the move-copy-reboot (after Permissions Repair) procedure in earlier threads, in case the file simply got corrupted. However, it's still not working.

    Anybody with a Rev A experience this and, if so, found a fix?

    TIA
     
  2. macrumors 6502a

    Joined:
    Oct 29, 2008
    #2
    Works fine for me. Got KEXT again, replaced, fixed permission, reboot, voila.
     
  3. thread starter macrumors 6502a

    Joined:
    Sep 13, 2007
    Location:
    Northern California
    #3
    Strange... I had to rerun fix disk permissions twice and both times it complained about the same permission problems. After the second reboot, I got my four-finger track gesture back...
     
  4. macrumors newbie

    Joined:
    Jul 28, 2008
    #4
    Works

    I replaced the same old kext replacement that I saved and forgot to repair permissions. Rebooted and trackpad + keyboard wouldnt work. Rebooted in safe mode, which apparently repairs permissions, and now all gestures work fine.... Rev. A of course.
     
  5. thread starter macrumors 6502a

    Joined:
    Sep 13, 2007
    Location:
    Northern California
    #5
    All working now. Thanks for confirming that the old "hack" still works. It made me stick with the procedure until I got it working again. :)
     
  6. macrumors 6502a

    slapguts

    Joined:
    Jan 10, 2008
    #6
    Sweet, the old hack worked perfectly for me, as well.

    Don't forget to repair permissions before restarting. Otherwise you'll lose your keyboard and trackpad. Glad I had a Jaadu VNC on the iPhone.
     
  7. h1d
    macrumors regular

    Joined:
    Nov 30, 2008
    #7
    For those who want to repair permission quicker, which completes in 0.1 second.

    Code:
    cd /System/Library/Extensions/AppleUSBMultitouch.kext
    sudo chown root:wheel .
    sudo find . -type d -exec chmod 755 {} \;
    sudo find . -type f -exec chmod 644 {} \;
    sudo find . -name AppleUSBMultitouch -exec chmod 755 {} \;
    sudo find . -name MultitouchHID -exec chmod 755 {} \;
    
    Type this in terminal. (Type your own pass once when asked.)
     
  8. macrumors 65816

    Joined:
    Aug 18, 2005
    #8
    For the record, the version number the AppleUSBMultitouch.kext was:

    v189.29.1 (10.5.6)
    v189.32 (10.5.7)
    v189.35 (10.5.7)

    I tend to just edit the kext myself - it's just adding six lines of text, but you have to be aware that the kext itself it stored in a cache (Extensions.mkext), so often a couple of reboots and invokes of the cache are required.
     
  9. thread starter macrumors 6502a

    Joined:
    Sep 13, 2007
    Location:
    Northern California
    #9
    Aha! That was probably my problem. It took three reboots to re-activate the four-finger trackpad gesture for my MBA...
     
  10. macrumors 6502

    Joined:
    Mar 22, 2009
    Location:
    Rockville (Despite REM's plea.)
    #10
    This got me wondering, and in the man page for kextcache, I found this little gem, which might solve this problem for future updates:

    NOTE: Kernel extension installers should not use this program to update caches. Instead they should merely touch(1) the /System/Library/Extensions directory after they have finished, which will cause the system to update all necessary kernel extension caches.
     
  11. thread starter macrumors 6502a

    Joined:
    Sep 13, 2007
    Location:
    Northern California
    #11
    Nice find! Thanks! I'll try to remember that next time
     
  12. macrumors 65816

    Joined:
    Aug 18, 2005
    #12
    You can watch it happen. Right underneath Extensions.mkext (which I believe to be the first cache file), a temp file will be created before replacing the .mkext.
     
  13. macrumors newbie

    Joined:
    Mar 14, 2010
    #13
    My keyboard and my trackpad both are not working. I tried to replace the hacked file with the 'real' AppleUSBMultitoch.kext and still- my keyboard and my trackpad are dead.

    So, I think I need the hacked file that you have (please post here the link) and than I'll do reboot in safe mode(how am I doing this??)
    THANKS
     
  14. macrumors 6502

    Joined:
    Mar 22, 2009
    Location:
    Rockville (Despite REM's plea.)
    #14
    It's possible that it's a hardware problem; however, do the keyboard and trackpad work as the computer is booting? If they do, then maybe you should look into resetting the SMC:

    SMC -- http://support.apple.com/kb/HT1411

    and possibly the PRAM

    PRAM and NVRAM == http://support.apple.com/kb/HT1379

    To boot into single user mode, you need to hold down the Command and S keys as the machine boots.
     
  15. macrumors newbie

    Joined:
    Mar 14, 2010
    #15
    on safe mode both working, and also while rebooting..
    the problem caused while trying to re-active the four fingers multi-touch feature after an update to 10.5.8, both my keyboard and my trackpad are not working. I tried to replace the AppleUSBMultitoch.kext but still- I have an alert that this file is not installed correctly (every time I turn on the macbook pro)
    I think that all this happen because my "repair permissions" doesn't work correctly- it's always repair the same things, and the AppleUSBMultitouch.kext is not on that list!


    How can I make my disk utility repair things?!
    Someone know what I need to do in order to repair the keyboard & trackpad?
    All the SMC rebooting is related?
     
  16. macrumors 6502

    Joined:
    Mar 22, 2009
    Location:
    Rockville (Despite REM's plea.)
    #16
    If you have an external keyboard/mouse, you can use disk utility to repair the packages; however, if you don't, you can try booting into safe mode, mounting the file system and running:

    repair_packages --repair --standard-pkgs
     
  17. macrumors newbie

    Joined:
    Mar 14, 2010
    #17
    I'm now in safe mode but a regular repairing permissions still repair the same things!
    and I did not understand what should I do with the "repair_packages --repair --standard-pkgs"

    Should I run it on terminal?
     
  18. macrumors 6502

    Joined:
    Mar 22, 2009
    Location:
    Rockville (Despite REM's plea.)
    #18
    Sorry, yes...

    /usr/libexec/repair_packages --repair --standard-pkgs

    This can also be accesses via pkgutil command using the --repair.

    Poking around on my system, AppleUSBMultitouch.kext is part of 3 pkgs

    pkgutil --file-info /System/Library/Extensions/AppleUSBMultitouch.kext
    volume: /
    path: System/Library/Extensions/AppleUSBMultitouch.kext

    pkgid: com.apple.pkg.BaseSystem
    pkg-version: 10.5.3.1.1.1188305148
    install-time: 1233381189
    uid: 0
    gid: 0
    mode: 40755

    pkgid: com.apple.pkg.update.os.10.5.7
    pkg-version: 1.0.1.1191932192
    install-time: 1242176533
    uid: 0
    gid: 0
    mode: 40755

    pkgid: com.apple.pkg.update.os.10.5.8
    pkg-version: 1.0.1.1191932192
    install-time: 1249516851
    uid: 0
    gid: 0
    mode: 40755

    So, you can run the following from the terminal..

    pkgutil --repair com.apple.pkg.BaseSystem
     
  19. macrumors newbie

    Joined:
    Mar 14, 2010
    #19
    I don't know what all of this pkg that you wrote.. but I did run "pkgutil --repair com.apple.pkg.BaseSystem" in the terminal and it did a lot of things.. also errors and missing things.
    :\
     
  20. macrumors 6502

    Joined:
    Mar 22, 2009
    Location:
    Rockville (Despite REM's plea.)
    #20
    Did it help after rebooting?
     
  21. macrumors newbie

    Joined:
    Mar 14, 2010
    #21
    Nope.
    :(
     
  22. macrumors 6502

    Joined:
    Mar 22, 2009
    Location:
    Rockville (Despite REM's plea.)
    #22
    Bummer. If you move the original back into place, does the keyboard and trackpad at least function w/o gestures.
     
  23. macrumors newbie

    Joined:
    Mar 14, 2010
    #23
    I don't have the original for MBP
     
  24. macrumors newbie

    Joined:
    Mar 14, 2010
    #24
    Thanks for helping me! I finally got it right! (after 2 times of Combo update and a lot of terminal things..)

    THANK YOU!! :)
     

Share This Page