1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

About This Mac "Storage" Inaccurate

Discussion in 'OS X Mountain Lion (10.8)' started by Aznboy1993, Jul 25, 2013.

  1. macrumors newbie

    Aznboy1993

    #1
    I recently formatted my MacBook Pro 13" Mid-2012 and restored from the most recent Time Machine backup using Migration Assistant. Upon getting everything all setup I came across this issue with "About This Mac." The actual space taken and space free is correct, but the space division is wrong. The graph shows everything as "Other," but the numbers shows that "Movies" and "Photos" comprise of some huge (truncated) amount of who knows what.

    [​IMG]

    I have tried clearing and redoing the "Spotlight" cache both via the GUI as stated via Apple's support site and some Terminal commands. No dice either way. I know this is a very minor issue that does not affect system performance or stability, but the OCD side of me is really itching to solve this problem. Anyone have any ideas?
     
  2. macrumors 68020

    #2
    When you say "clearing and redoing the Spotlight cache", do you mean reindexing the drive, or something else?
    What exactly did you do, i.e. what commands did you type; or what options in what utility did you use?
    You are right that this is usually a Spotlight error, but there may also be a bug in ML (look at the size of the Movies and Photos.)
     
  3. macrumors 6502a

    #3
    I also have this bug where my "Movies" section shows 18.45 EB!!!

    I have tried doing the Spotlight fix by adding and removing my Macintosh HD to re-index spotlight but it was still screwed up
     
  4. macrumors demi-god

    GGJstudios

    #4
    18.45EB of movies shown

    Try re-indexing your drive: If that fails to index, enter the following command in Terminal:
    sudo mdutil -i on "/Volumes/your drive name"​
     
  5. macrumors 6502a

    #5
    I've seen that thread and tried the solution everyone recommends, it didn't seem to work. My spotlight re-indexed for 20 minutes and when I checked again it was still 18.45 EB
     
  6. macrumors demi-god

    GGJstudios

    #6
    Did you try the Terminal command I posted?
     
  7. macrumors newbie

    Aznboy1993

    #7
    Yeah I have tried literally everything. Before I posted this thread asking for help I scoured the internet best I could to see what I could do to rectify the problem. Sadly, no dice.

    I have tried this. Nothing. Even the follow Terminal commands:

    sudo mdutil -E / (deletes Spotlight cache and reindexes)
    sudo mdutil -a -i on (even tried to make sure it's on)
    sudo mdutil -a -i off (tried to turn it off and back on again)

    Nothing!!! I was literally gonna pull my hair out at that point...I'm thinking about doing another reformat and not using Migration Assistant (maybe something got borked whilst transferring) and manually recover my data/settings. Ugh...
     
  8. macrumors demi-god

    Weaselboy

    #8
    Try a command-r boot to recovery, then start Disk Utility and run a repair disk on the main drive.

    This command (below) you mentioned should reindex Spotlight for all mounted volumes, which usually fixes this, so you have something else going on.

    Code:
    sudo mdutil -E /
     
  9. macrumors newbie

    Aznboy1993

    #9
    Yup I have tried to do both a disk repair and permission repair (to both the disk itself and my OS X volume) using OS X Recovery. No joy. I don't know what else to do. :(
     

Share This Page