Accessing Windows PC from iBook. Shared internet.

Discussion in 'macOS' started by fBaran, Jul 16, 2006.

  1. fBaran macrumors regular

    Joined:
    Oct 22, 2003
    #1
    Hey all, I have a Windows XP Pro machine and an iBook here. The iBook gets Internet from its Airport card, and the PC gets Internet shared from the iBook (ethernet port share). I can access the iBook from the PC fine, but cannot do so the other way around.
    • The iBook is on \\x.x.x.x\iBook
    • Windows Sharing is ON
    • iBook Firewall is OFF
    • PC Firewall is OFF
    Any ideas on what the problem could be? Thanks!
     
  2. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #2
    Okay, here's the setup

    1) Go to Sharing in System Preferences

    [​IMG]

    2) Enable Windows sharing

    3) Click on Accounts

    [​IMG]

    4) Enable your user name to access Windows sharing

    5) Exit, and go to the Go menu in the finder bar

    [​IMG]

    6) Go to Connect to Server, and you'll get this

    [​IMG]

    7) click connect.

    8) Connect to SharedDocs. :)
     
  3. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #3
    You may also want to check the firewall permissions on your Windows computer. Also try pinging your computer by going to Terminal and ping xxx.xxx.xxx.xxx, you may also have to enable File and Printer sharing on your end in Windows. :)
     
  4. fBaran thread starter macrumors regular

    Joined:
    Oct 22, 2003
    #4
    Ok, smb://alayna is the windows computer name I assume? When I type that in (with my windows' comp name instead), I get this:
    [​IMG]



    On the bright side, I can browse in the Finder to where the windows computer is (blackbox), but when I click connect:
    [​IMG]

    In Directory Access, under SMB/CIFS, my workgroup name is WORKGROUP, and blackbox is the same.
     
  5. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #5
    That means your Windows computer isn't sharing. :)

    You need to go into Control Panel, go to Network and Internet Connections, click on Set up or change your home or small office network, and when it gets to Sharing, allow Sharing. You will also need to change the workgroup name, as Windows XP likes to assign a different workgroup name (MSHOME). Change MSHOME to workgroup and then your fine. You might also need to restart, lower firewall stuff, yada yada yada. And then try. :)
     
  6. fBaran thread starter macrumors regular

    Joined:
    Oct 22, 2003
    #6
    Done, and done. Both computers restarted, but still no dice. Is there something else I could be overlooking?
     

Share This Page