Ad Hoc build not registering for push notifications

Discussion in 'iOS Programming' started by SimonBS, Mar 21, 2011.

  1. SimonBS, Mar 21, 2011
    Last edited by a moderator: Mar 21, 2011

    macrumors regular

    SimonBS

    Joined:
    Dec 30, 2009
    #1
    Hi,

    I have an application which I would like to enable push notifications on. I have had it working with my developer build and then I wanted to make an ad hoc build.

    I installed the Ad Hoc build on my iPhone and it is working fine. Then I tried an iPhone in the family but it does not register for push notifications. The application is not showed in settings (where settings for push notifications are made), there is no alert asking the user to activate push notifications on the first launch and the device is not registered in my MySQL database.

    I am using the PHP library "Easy APNs" and it should be set to use both development and production certificates - anyways, I don't think that's where the issue is as there are no actions from to phone to try to register for push notifications.

    Does anyone have an idea what I can be doing wrong?

    EDIT:

    When I read the mobileprovision files (under "Settings" on the iPhone), I can see that the mobileprovisioning file on my iPhone is newer than the one on the other iPhone. Mine is from today while the other is from the 20th of February.
    Could this be the issue and if so, how would I make sure that the other iPhone gets the newest mobileprovisioning file?
     

Share This Page