Ads Slowing Me Down

Discussion in 'Site and Forum Feedback' started by TheMonarch, Oct 14, 2005.

  1. TheMonarch macrumors 65816

    TheMonarch

    Joined:
    May 6, 2005
    Location:
    Bay Area
    #1
    What has been happening for a couple of days is that when browsing MR, Safari's progress bar loads like normal except when nearing the end. It just stops. But then if I click on the stop button, everything appears like normal, except something is missing... The ads. It seems that the reason Safari stalls is because its waiting for the google ads to load. I know I could view MR ad free if I become a contributer, I plan to (but hey, I am currently a broke college student :eek:)


    Anyways, I've attached a snapshot. Its MR ad free. Has anyone else had this "issue"?
     

    Attached Files:

  2. tech4all macrumors 68040

    tech4all

    Joined:
    Jun 13, 2004
    Location:
    NorCal
    #2
    Yea I've experienced this before, and not only on MacRumors but other sites that have ads as well. When the load bar is at ~95% I click STOP and the page loads without the ads usually.

    And as for the ad free stuff with contributing; I believe you only get an ad-free Front page, the forums still have ads though.
     
  3. arn macrumors god

    arn

    Staff Member

    Joined:
    Apr 9, 2001
    #3
    Sorry about that. as been said before. sometimes ad servers become a bottleneck... but usually not google's.

    Ads provide support for this site and funds the three dedicated servers as well as future growth. As for as ads go, I think MacRumors' has a relatively good balance of ads and content.

    I frown upon any un-approved methods of remove ads from this site, and any instructions for that will be removed. Sorry, but I think this is a reasonable expectation.

    However, you can get front page ads removed by contributing. I'll look into extending that ad removal into the forums.

    arn
     

Share This Page