Advice For New Developer

Discussion in 'iPhone/iPad Programming' started by peter1234, May 8, 2009.

  1. macrumors newbie

    #1
    I've joined the Apple Developer programme and I notice that the iPhone 3.0 beta page it says "iPhone SDK for iPhone 3.0 beta is for development purposes only. This software should only be installed on devices dedicated exclusively for iPhone 3.0 beta application development."

    As someone who is just starting in this I only have one iPhone, not one dedicated to application development. Is there really a risk of wrecking my iphone if I load the 3.0 beta?
     
  2. macrumors regular

    #2
    You might as well work off the Simulator for now. The 3.0 should be released in the summer. If you want to submit to the App Store right now, it needs to be compiled and tested under 3.0. So at that point, yes you will have to take a chance on your only device. It's probably best to just download the 3.0 beta SDK and learn on that since 2.2 is going to be gone soon.
     

Share This Page