1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

AE to wired router = works with Mac's but not iPhone

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Qwerty11, Jan 27, 2013.

  1. macrumors regular

    So I have a dLink router and and AE. the AE is connected to the dLink. My mac's will connect and run fine off of the AE, but the iPhones will connect, but exchange minimum amounts of data. Could somebody help me out?

    The dLink has the following settings.

    My Internet Connection is : Dynamic IP (DHCP)
    Advanced DNS service : Not Enabled
    Use Unicasting: Yes
    Wireless Enabled: No
    Enable DNS Relay: Yes
    Enable DHCP Server: Yes
    Always Broadcast: Yes
    Enable QoS Engine: Yes
    Automatic Uplink Speed: Yes
    Enable SPI Firewall: Yes
    Enable anti-spoof checking: No
    Enable UPnP: Yes
    Enable WAN Ping Respond: Yes

    The AE has the following settings:
    Connect Using: DHCP
    Network Mode: Create a wireless network
    Router Mode: Off (Bridge Mode)
  2. macrumors newbie

    That last setting doesn't look right to me. I'm not at my AE so I can't check which way the flag should be, but if router mode is off, then your AE is in bridge mode (at least, that's the way I parse that last line). If your AE is in bridge mode, then it's expecting another router to bridge to.

    Instead, you're connecting user devices to your Airport Extreme/Express, so that's the end router in the chain. Therefore it should be in Router Mode.

    [If I've interpreted the Router Mode flag in the wrong direction, then everything I've said is wrong.]

  3. macrumors regular

    Something is definitely wrong the iPhone will connect to the AE but not receive data.

    I'm betting using the AE as a print hub won't work as well.

    Somebody help!
  4. macrumors newbie

    Is the router running your DNS Service or not?

    Advanced DNS service : Not Enabled
    Enable DNS Relay: Yes
  5. macrumors regular

    I'm a complete dummy on networking so I do not know.
  6. macrumors newbie

    open terminal on your mac and write
    scutil --dns

    Look up "resolver #1" for the IP of -> nameserver.
    In airport utility put in the IP-adress at DNS settings.
  7. macrumors member

    BRIDGE mode

    The AE has the following settings:
    Connect Using: DHCP
    Network Mode: Create a wireless network
    Router Mode: Off (Bridge Mode)
    <--------------------- Change to bridge mode.

    This allows you to bridge the 2 physical networks. Make sure you have DHCP with the same scope running on your router.
  8. macrumors G5


    Are you using AE to extend the network or to have a faster network?

    Are all devices running on your AE router?
  9. macrumors regular

    I'm using AE because it works great with all my apple products. Don't really have any better reason.The AE needs to be just for WI-FI not the router. I want the d-link to handle the routing.
  10. macrumors regular

    Thx, but it is already set with the resolver 1 DNS.


    If I'm not mistaken Off (Bridge Mode) is in bridge mode. The other two options are "DHCP and NAT" and DHCP Only.


    For some reason when using airport utility on the iPhone the AE always is shown as green, but the "internet" keeps going from green to yellow and back again. When I click on it connection switched from Connected to Disconnected. The router and dns servers are

    My wireless connection on my macs is solid.
  11. macrumors regular

    Anybody have any ideas?
  12. macrumors demi-god


    Have you got the airport utility app on your iphone??
  13. macrumors regular

    Yes. I is green for AE but intermittently changes from green to yellow for internet.
  14. macrumors demi-god


    Have you updated the airport? Because the last firmware or the one before that caused this issue for a lot of us.
  15. macrumors regular

    Probably not unless it auto updates. I'm guessing I do this through airport utility?
  16. macrumors regular

    I updated my iPhone to 6.1 and everything started working correctly!

Share This Page