Agent18 60G Videoshield Wetspot Problem

Discussion in 'iPod' started by gantha, Dec 17, 2005.

  1. macrumors newbie

    Dec 17, 2005
    Hi. I just got my agent18 60G case and when I put it on my white ipod I notice wetspots on the left and right side of the clickwheel. It is also on the backside. i cleaned the case and my ipod many times and put it back on but the spots are still there. the spots looks like thin vertical lines. anyone have this problem? should i use a film first? also anyone have agent18 phone number? thanx.:mad:
  2. macrumors member

    May 1, 2005
    Fairfax, VA
    I have similar spots, it sounds like. Mine are on a 30 gig black iPod, also with the Agent18 case. What did you use to clean yours? I used iKlear, and it does leave behind a film. I figured that was why. Interesting.
  3. macrumors 68030


    Jun 24, 2004
    Both of you should look on the varying threads on iLounge to do with the clear case problems on both the nano and 5G. It seems they all can suffer from this problem. I had the Contour iSee and Power Support Crystal Jacket for my nano and had the exact same issues. Initially a couple of folks - me included - who put it down to our cleaning problems, but people who had never used anything like iKlear or IceCreme had the same issues.

    Basically it just an problem that exists and there is little that can be done about it unfortunately. I gave up and got a Core Case for my nano instead and couldn't be happier.
  4. macrumors G4


    Jul 4, 2005
  5. thread starter macrumors newbie

    Dec 17, 2005
    Agent18 60G Videoshield Wetspot Problem Reply to Thread

    Thanks guys. I cleaned mine with just a cloth. ilounge reports the same problem. contacting agent18 is slow; no phone number!

Share This Page