Air Not "Remembering" Screen Brightness?

Discussion in 'MacBook Air' started by $MacUser$, Mar 7, 2012.

  1. macrumors 6502

    Joined:
    Mar 27, 2005
    Location:
    Los Angeles
    #1
    I'm a little annoyed by the fact that my Air won't "remember" the brightness I set for the screen. This is especially important for running on battery power, and in general for the longevity of the panel.

    I jump into work and forget to bump it down. Without fail it always reverts to 100% brightness by default. What's up with that? I do shut down from time to time to preserve standby power and occasionally plug in an external monitor...would this be "erasing" my brightness settings?

    Just sleeping and waking doesn't seem to have an impact.
     
  2. macrumors 68000

    KylePowers

    Joined:
    Mar 5, 2011
    #2
    Well, unless you changed anything, it should change depending on your surroundings. If it's bright, it'll kick up the brightness. If it's dark, the screen should dim. But if you don't like it doing that, you can just go to System Preferences -> Displays and disable 'Automatically adjust brightness'

    Unless this is what you've already done and it's not remembering it?
     
  3. thread starter macrumors 6502

    Joined:
    Mar 27, 2005
    Location:
    Los Angeles
    #3
    I always disable automatic right out of the box, and it's still disabled. I know just sleeping and waking won't impact the brightness setting, just from working on it now. So I don't know whether going to and from A/C, to and from external, or shutting down (or some combination of these), is causing the computer to forget the "off AC" brightness setting.

    Really annoying...it's easy to forget, especially in a bright environment, and there goes my battery power...
     
  4. macrumors 604

    onthecouchagain

    Joined:
    Mar 29, 2011
    #4
    Same thing happens to me. I too find it obnoxious that it changes it every time I plug/unplug charger.
     
  5. macrumors 68040

    chrf097

    Joined:
    Dec 16, 2011
    Location:
    Earth
    #5
    Make sure that the "Slightly dim the display...." option under "Energy Saver - Battery" is turned off.

    [​IMG]
     
  6. thread starter macrumors 6502

    Joined:
    Mar 27, 2005
    Location:
    Los Angeles
    #6
    Already have that taken care of. I think it's an issue whereby plugging in to an external monitor and running clamshell resets the built-in screen brightness.
     
  7. macrumors 68040

    chrf097

    Joined:
    Dec 16, 2011
    Location:
    Earth
    #7
    Did you also uncheck the option underneath it?
     
  8. thread starter macrumors 6502

    Joined:
    Mar 27, 2005
    Location:
    Los Angeles
    #8
    Yup and yup. I noticed this is happening after plugging into an external display. It seems to reset everything but my sleep time settings.
     
  9. macrumors newbie

    Joined:
    Aug 29, 2014
    #9
    I have exactly the same problem, so annoying.
    Did anyone find any fix/ workarounds?
     

Share This Page