Air won't start

Discussion in 'MacBook Air' started by DP812, Mar 28, 2010.

  1. macrumors regular

    Joined:
    Aug 13, 2009
    Location:
    Japan
    #1
    My MacBook was going really slow and I performed a forced shut down because it kept freezing. When I tried to start up again, it wouldn't boot past the Apple logo and the spinning wheel. I was told hold command, p, r and control while restarting could fix this so I tried. After that, the computer suddenly shut down shortly after getting to the boot screen.

    Disk Utility won't work because it shuts down before it loads. Same for safe mode. It works in single-user mode and fsck returned the following:

    disk0s2: I/O error.
    Invalid node structure
    (4, 0)
    Invalid B-tree node size
    (4, 0)
    Invalid node structure
    (4, 0)
    Invalid B-tree node size
    (4, 0)
    ** The volume could not be verified completely.
    /dev/rdisk0s2 (hfs) EXITED WITH SIGNAL 8

    Any help with this would be greatly appreciated.
     
  2. Moderator emeritus

    Hellhammer

    Joined:
    Dec 10, 2008
    Location:
    Finland
  3. thread starter macrumors regular

    Joined:
    Aug 13, 2009
    Location:
    Japan
    #3
    Tried everything in the guide with no luck. Computer shuts down before it can even book from the install disc.
     
  4. Moderator emeritus

    Hellhammer

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #4
    Hmm, sounds like a PSU/battery/logic board issue. Do you have warranty left? If so, contact Apple and get it fixed
     
  5. thread starter macrumors regular

    Joined:
    Aug 13, 2009
    Location:
    Japan
    #5
    I don't think it's a power issue because it doesn't restart when I'm in single-user mode. Only when I try to boot.

    It's about a year and a half old so no warranty left. I've seen DiskWarrior mentioned a lot so I just ordered a copy of that.
     
  6. macrumors newbie

    Joined:
    Mar 30, 2010
    #6
    I also have in front of me a MBA (rev B with SSD) which will not start anymore. I am not sure whether the problem is the same, so, for now I just post here, if you prefer me to create a new thread, just let me know.

    I have rEFIt installed on it, and it is dual boot with Linux (Gentoo) and Mac OSX. I get to rEFIt, and can choose my OS. Now, none will start. Actually, even booting from a CD (Mac OSX 10.5 or Linux Ubuntu live CD) will not work either.
    If I try to boot OSX, I get the apple logo, and then a circle with a line across it (seems like a failure icon), on the same grey screen as the logo. Trying to boot linux will result in a "non bootable device" fatal message, prior it even gets to its own bootloader.

    I have tried both resets of PMU and SMC, and none helped (same for the above guide btw).

    Any idea, before I send it back to Apple another time ? (except that now I start to be really tired with this computer: since august, the only thing I did with it was to go to the Apple store again and again... a dog would be more useful).

    Ps : not sure it may be related (I think not, since the issue occurs whatever OS I try to boot): I upgraded to 10.6.3 yesterday.
     
  7. macrumors 6502a

    Synchromesh

    Joined:
    Jul 15, 2009
    Location:
    SF
    #7
    Sounds like it's either the disk or the logic board. If you can get a hang of another disk I'd try that. But I'm guessing it's the logic board.
     
  8. macrumors 6502a

    iDisk

    Joined:
    Jan 2, 2010
    Location:
    Menlo Park, CA
    #8
    If your close, go to the nearest Apple Store or call and set an appointment.

    Or

    AppleCare
     
  9. macrumors 6502a

    drummerlondonw3

    Joined:
    Feb 10, 2008
    Location:
    London

Share This Page