airplay interrupting appletv viewing

Discussion in 'Apple TV and Home Theater' started by treyb, Dec 7, 2010.

  1. macrumors member

    Joined:
    Jul 21, 2008
    #1
    My girlfriend is in the other room watching the atv2 and I'm in my office on my imac that the atv2 is talking to. I added a couple files to itunes and it auto-plays directly to airplay, interrupting whatever is playing (both netflix and itunes streaming have been interrupted).

    I checked the airplay settings and viewed for a few seconds on the computer before closing and playing another file which started in airplay. I'd suffice with a setting to turn off auto-play when adding, but I'd really like to find out why it is sending to airplay everytime.
     
  2. macrumors member

    Joined:
    Nov 29, 2007
    #2
    Thats wild- are you adding music or movie files that interrupt? How are you adding them? Windows or osx?
     
  3. thread starter macrumors member

    Joined:
    Jul 21, 2008
    #3
    drag and drop to the dock with osx

    its all video files that I've tried so far.
     
  4. macrumors member

    Joined:
    Nov 29, 2007
    #4
    Drag and dropping to dock is the same as opening, so I imagine it will auto-play every time- might have to just use File-Add to library... to prevent auto play.

    As far as airplaying when opening, the only way I could get this to happen is if I had been previously airplaying that file and closed it then re-dropped it to the dock- all new files dropped opened in iTunes.
     
  5. thread starter macrumors member

    Joined:
    Jul 21, 2008
    #5
    they are new files dropping into itunes. and the first in the sequence being dropped starts playing via airplay, not even playing video on my screen. I'm guessing since you dont have this happen i have an odd setting ticked somewhere.
     
  6. macrumors member

    Joined:
    Nov 29, 2007
    #6
    I can get any file now dropped into the dock to airplay if I leave the aTV2 selected in airplay settings- but always get a window to pop up on the computer.

    What setting do you have under preferences-playback-Play Movies and TV shows:

    Im sure thats not it, but curious
     
  7. macrumors member

    Joined:
    Nov 29, 2007
    #7
    found some hidden itunes preferences but none of them seem to apply to your sitch- sorry not much help, pretty odd
     
  8. thread starter macrumors member

    Joined:
    Jul 21, 2008
    #8
    full screen is selected. it confuses me cause if i play something from the music tab it plays on the computer and doesnt interrupt the atv2. but any video added, or already present stops playback. and initiates added or selected.
     
  9. macrumors member

    Joined:
    Oct 12, 2005
    #9
    I haven't had this problem with music. Do you have airplay selected on iTunes. Lower right corner. Or multiple speakers for that matter.

    Reset everything. I've found that helps quite a bit. UnPlug the Atv for 10 seconds and plug it back in. If that don't work, be a bud, and submit a bug to apple so it gets worked out.
     
  10. thread starter macrumors member

    Joined:
    Jul 21, 2008
    #10
    i think you misunderstand. my problems aren't that it won't work. its that it works too much. i want items to play from my computer before i sent them for airplay. i dont like that my computer auto airplays
     
  11. macrumors member

    Joined:
    Oct 12, 2005
    #11
    I understood that. Let me ask you this. In iTunes look to the lower right hand corner of iTunes. Do you see the airplay icon. Is it blue? Well it shouldn't be unless you want to stream to your tv.

    For a second there, I thought you found a bug.
     
  12. thread starter macrumors member

    Joined:
    Jul 21, 2008
    #12
    sorry i wasnt sure. the airplay icon is not blue and when clicking on it it says computer as the option. if i choose a new item or drag an item to itunes it will play via the airplay link to appletv. while i dont dislike this feature. this is not my desired result.
     

Share This Page