Airplay sound stuttering when using 5ghz

Discussion in 'Apple TV and Home Theater' started by stellahell, Feb 1, 2013.

  1. macrumors newbie

    Joined:
    Jun 28, 2012
    #1
    So I bought the new Airport Express for AirPlay use.

    I've set up a 2.4 ghz and 5 ghz network. I use the 2.4 ghz for iPhones and such and the 5 ghz for my MBP. Only problem is that the sound is stuttering and sometimes freezing when I use Airplay through iTunes on my MBP over the 5 ghz network. However, when I switch to the 2.4 ghz network there's no lag...

    Anyone else experiencing this and have any idea why it's stuttering when using the 5 ghz network - which should be much faster than the 2.4 ghz?

    I occasionally have similar stuttering issues with my iPhone 4 and 4S when using airplay even though the iphone is about 2 feet away from my airport express.

    It's starting to bug me that I can't use Airplay in a sensible way...:(

    Btw, it's a MBPr with Mountain Lion up to date.
     
  2. ThisOneHere, Feb 1, 2013
    Last edited: Feb 1, 2013

    macrumors newbie

    Joined:
    Feb 12, 2008
    Location:
    Upstate, NY
    #2
    I always had my iPhone on 5GHz (I have the latest gen Airport Extreme) and I noticed the same issue once I got my new Harman/Kardon AVR 1700 with AirPlay. I thought it was a problem with the receiver itself, but my buddy has the same setup and same receiver and was problem-free. It wasn't very obvious to me at first since I even had the receiver connected via Cat6 Gigabit Ethernet to my router, so only the iPhone was on Wi-Fi. We determined that the only variable between my buddy's setup and mine was that I was on 5GHz and he wasn't. I switched to the 2.4GHz network and haven't had any issues since with either AirPlay skipping or another problem I was seeing with the Harman/Kardon iOS remote control app "losing" sight of my receiver.

    I can only speculate as to why 2.4Ghz works better, but I assume it's related to a multicasting setting, using "wide-channels" with 5Ghz, or perhaps the channel being auto-selected by the 5Ghz band is conflicting with something else. Considering I really don't "need" 5Ghz on the iPhone, simply switching to 2.4Ghz wasn't too upsetting. I don't AirPlay much from my MBPr but I fully understand why this would be more annoying for you, as I wouldn't want my MacBook on 2.4Ghz or to have to switch back and forth.
     
  3. macrumors 68020

    Joined:
    May 27, 2008
    #3
    5GHz doesn't go through things as well as 2.4, so put a couple walls between you and the router, and you may have a better signal on 2.4.

    wifi can have problems if things are too close.


    wifi isn't an exact science, there are a lot of outside influences that come into play. construction of your building, furniture, other electronics, other wifi networks.
    i try to hardwire as much of my gear as i can for this very reason
     
  4. macrumors 6502a

    bohbot16

    Joined:
    Mar 22, 2009
    #4
    This. I've found that if you're using all Apple gear that setting the 2.4 and 5GHz networks to the same name and letting the devices sort it out works surprisingly well. I have had to manually select a 2.4GHz channel with this configuration, though, to reduce interference with neighboring apartments.
     
  5. thread starter macrumors newbie

    Joined:
    Jun 28, 2012
    #5
    Thanks for the replies, guys! I guess we won't come any closer to an actual solution, but I did learn a little regarding wifi :) But like waw74 said, it's not an exact science.
     
  6. macrumors G5

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #6
    One thing you could try is changing the channel setting from "Auto" to one of the other options there 40,41 etc. I have both my ATV's running on 5GHZ and they don't miss a beat.
     
  7. thread starter macrumors newbie

    Joined:
    Jun 28, 2012
    #7
    Cool. I'll give that a try when I get home :)
     

Share This Page