Airport doesn't connect to wlan

Discussion in 'Mac Basics and Help' started by virtual.rx, Jun 1, 2006.

  1. virtual.rx macrumors newbie

    Joined:
    May 17, 2006
    #1
    I just bought a Black MacBook and its totally wonderful!
    No moos or whines or whatever.
    Idles around 50C and under 2 dev/null terminals it maxes out at 80C which is ok. This is without any firmware upgrades due to the airport not connecting to my wlan network.

    I have a D-Link 524 router and have 2 pc's and an xbox360 connected to it.
    for some reason the mac doesn't want to connect even with the correct WEP key.

    Any ideas?

    ps. this is my first personal mac, i have had an g4 at work but now have a g5.

    This MacBook truly rocks!!
     
  2. x86 macrumors regular

    x86

    Joined:
    May 25, 2006
    Location:
    Dearborn, MI
    #2
    Does it pickup the signal and just not connect? Also, is your xbox and PC connected wirelessly? I know this is stupid, but are you sure the airport is powered on? Another thing to try would be to turn broadcast ssid on (if it isn't already), just to see if you can pick up the signal (if your not currently getting any signal).
     
  3. tag macrumors 6502a

    tag

    Joined:
    Apr 29, 2005
    Location:
    PA, US
    #3
    Just a thought, but try putting a '$' infront of the WEP key? Some Macs require that before the key for some reason, though I've never bothered to look into why. (I assume though it is an identifier, which tells that it is in hex as opposed to plaintext).

    If that doesn't work you might want to try connecting once without any encryption / security turned on. That way you can make sure the problem you are having is with the WEP key / encryption and not with something else such as DHCP or something.
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    There's more on what tag was saying about the dollar sign in this Apple Support Page. :)
     
  5. virtual.rx thread starter macrumors newbie

    Joined:
    May 17, 2006
    #5
    1. ASCII password
    If you were given a password that may be plain language, containing characters from the full range of ASCII, use the double quotation mark (") before and after the password. These are case-sensitive, and they are five characters long for 40-bit encrypted networks or 13 characters long for 128-bit encrypted networks.

    Example of 40-bit: "pw123"
    Example of 128-bit: "password12345"

    2. Hexadecimal password
    If you were given a password that uses only the hexadecimal range of characters (which are: abcdef0123456789), put a dollar sign ($) before the password. These passwords are 10 characters long for 40-bit encrypted networks or 26 characters long for 128-bit encrypted networks. In a hexadecimal password, the dollar sign is called the Hex Escape. It notifies the software that the characters that follow it should be treated as a hexadecimal number. Other possible hex escapes are "0x" and "0X" (zero-x, and the "x" may be upper or lower case).

    Example of 40-bit: $1234abcdef
    Example of 128-bit: $12345678901234567890abcdef



    Should I make a new key with the network utility (D-Link) for the whole network or do I just enter the already exsisting key with a $ ?

    The D-Link setup doesn't accept $ as a hex.
    And using " it counts the " as a sign so i only enter like "pwd"


    Thanks guys!
     
  6. gekko513 macrumors 603

    gekko513

    Joined:
    Oct 16, 2003
    #6
    The " wasn't really supposed to be part of the password on the d-link. They ment just pw123, but anyway, it doesn't matter.

    If the d-link is set up with a hex-password try using $ in front of the hex password without changing anything on the d-link. Remember it has to be followed by exactly 10 characters for 40-bit wep and exactly 26 characters for 128-bit wep.

    The d-link does not use the $ notation, so you should just use the part that comes after the $ on the d-link. It should have it's own options and it should say something about hex and 26 characters.
     
  7. virtual.rx thread starter macrumors newbie

    Joined:
    May 17, 2006
    #7
    I got it to work!

    WPA-PSK instead of WEP did the trick!

    Thanks guys!

    ps. I love this Black Macbook to death! It's a perfect one!
     

Share This Page