Airport Express is causing me to dislike Apple

Discussion in 'Macintosh Computers' started by johnny_boy9, Jan 20, 2005.

  1. macrumors newbie

    Jan 20, 2005
    Okay, I admit it, I own a PC, well several.. But I do love Apple products, iPod, iBook, and now the Airport Express - sorta.

    I have an existing Wireless network running a a linksys router. My computer (PC) is connected to that router through cat 5 cable, but there are some wireless PCs connected to the router, mine isnt one of them.

    I have iTunes on my PC, and I wanted to stream it through my router down to my stereo. So I bought Airport Express assuming I could do this (I still think I can). Anyways, my setup looks like this:


    Anywhoo, I plug in Airport Express to the wall like the instructions say, and it can't detect my network, or will not connect to it. It just flashes amber. Now, it is in range (its in the same room) and I disabled mac filtering just to make it easy for it to connect, and even disabled WEP... No such luck. It will not connect. And when I open that Admin program, I try and put in the IP and password for my linksys router but I get a "-4" error or something, basically it can't collect the settings.

    Now I can connect to the airport express to some extent. I installed the software on my wireless computer and it does detect the APE as a network so I see mine, my neighbours and stuff, then teh APE. I did connect to it on that computer but I believe that it was thinking I was using it as a router, when all I want it to be is a client.

    This is very frustrating and I'm hoping one of you guys could help me out!
  2. Guest


    Jun 3, 2002
    does the linksys do bridging mode??? have you set both base stations to bridge (WDM iirc) on Apple's.
  3. thread starter macrumors newbie

    Jan 20, 2005
    As far as I know you only need to bridge if you want APE to repeat the signal? I do not need it to do that, just hop on my network. However, assuming I did need to do that I have no way of getting into the APE settings because it will not allow me to change anything. It looks like the only settings I can set on it are when I connect to it with the wireless computer and the APE thinks that it is the only router.
  4. macrumors 6502a

    Jun 8, 2004
    Hook your computer up to your AirPort Express with an Ethernet cable, and configure it so it joins your Linksys router's network in "client-mode". This will allow you to do AirTunes and Printer Sharing from it. It won't show up as it's own Wireless network, it will join your current one.
  5. macrumors 68020


    Apr 5, 2004
    Huntsville, AL
    You have to configure the Airport Express before it will join your Linksys' network. Out of the box, it serves out its own network. Try plugging the Express into your wired network and run the configuration application. I used my Powerbook to configure mine, but that should do the trick.

    I'm using my Express w/ a Linksys 802.11b wireless router (BEFW11S4) using WDS and it works flawlessly. All I did was add the Express' MAC to my router's MAC access list and setup the Express to connect via WDS. That's it.
  6. macrumors regular


    Jan 6, 2004
    Kahuku, Hawai'i
  7. thread starter macrumors newbie

    Jan 20, 2005
    Thanks for your help! It all works smoothing now. What confused me in the documentation is that it said it should "connect from the box".. but that clearly wasn't the case. I guess that's geared towards Airport owners.

    But yeah, excellent product, I love Air Tunes now. Mr. Jobs is back in my good books. :D
  8. macrumors 68000


    Jul 26, 2004
    Burlington, VT
    I think they should use your drawing in the manual that comes with the Express, it is great!

    Somehow it works and makes the whole thing seem so simple.
  9. macrumors G3

    Chip NoVaMac

    Dec 25, 2003
    Northern Virginia
    You have a point. Nice technical drawings are fine. But for a home user they might "connect" better to something that looks more like what they might draw. I could easily understand his needs (though had no answers).

Share This Page