Airport Extreme and UPnP, Xbox, Vizio TV, and other issues

Discussion in 'Mac Accessories' started by rceee, Jan 6, 2012.

  1. macrumors member

    Joined:
    Aug 21, 2007
    Location:
    New Orleans
    #1
    This Christmas I decided to get the new Airport Extreme router. I have a perfectly fine working D-Link router, but I liked the USB capability of the AE and its tighter integration with my Apple products (iPhone 4, iPad 2, Macbook Pro, and Apple TV).

    I got home and set it up, and everything was working great. All the Apple devices were hopping along and even seemed a bit faster.

    The problem came when I attempted, the next day, to utilize my Xbox 360, and my top-of-the-line Vizio 3D HDTV.

    The Xbox responded with an error, after connecting to the Airport Extreme, saying that I needed to enable UPnP. The Vizio TV connected wirelessly via WPA (or probably WPA2), but then various apps would not work, such as the Amazon Video streaming app, Netflix, Hulu, etc.

    After some research, it appears that surprisingly, the Airport Extreme does not support UPnP, which as I understand it, handles the closing/opening/forwarding of ports related to various devices and their softwares/apps. Some posts talk at length about setting the Xbox360 to be in the AE's DMZ, or to set up port forwarding, but seemed somewhat generally inconclusive. I could find no similar documentation/advice regarding the Vizio HDTV and its respective video streaming apps.

    It's been a long time since I've even had to *think* about setting up port forwarding on a router, and I'm guessing that even if it could be figured out on the Xbox360, finding out all of the ports and such utilized in the Vizio HDTV apps could be impossible.

    Am I missing something here, or is this really a major problem? I really have trouble believing that such a fundamental feature could be missing from such an expensive Apple router... A device touted as, in some ways, the ultimate home router, given its compatibility with Apple devices, all the bells and whistles one usually wants in a router (dual band antenna, guest network capability, USB capability, etc). Is there not some way to simply enable UPnP and be done with it, so that my Xbox360 and my HDTV will go back to working, simply, as they did with my previous D-Link router? Or am I just screwed?

    Any advice or insights into this matter would be greatly appreciated. Thank you all for any help you can provide.

    Kindest regards...
     
  2. thread starter macrumors member

    Joined:
    Aug 21, 2007
    Location:
    New Orleans
    #2
    Nobody's using an Airport Extreme with HDTV built-in streaming apps reliant on upnp?
     
  3. Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #3
    I'm not sure why your XBox isn't working and advising UPnP to be enabled. I have my XBox 360 hooked up via Ethernet to my AEBS and it works just fine. UPnP is strictly a Microsoft protocol developed in the early 2000's and was quickly found to be a terribly bad security vulnerability.

    From GRC.com
    If you're using OS X, you don't have anything to worry about, but if you use a Windows machine, you should disable it unless you really, really need it. GRC.com provides a nice utility to disable it.

    But still your XBox should work regardless of this, as mine does. I don't have any port forwarding/mapping set up in my AEBS at all.

    Have you tried to reset your XBox to its factory settings?
     
  4. thread starter macrumors member

    Joined:
    Aug 21, 2007
    Location:
    New Orleans
    #4
    Yeap, I did. If there's no upnp, how can the router know where to forward the ports to at the 360?

    And what about the HDTV's video streaming apps (Netflix etc)?
     
  5. SandboxGeneral, Jan 9, 2012
    Last edited: Jan 9, 2012

    Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #5
    I'm not really sure, but I'll do some digging. My XBox works fine, Netflix works via the XBox and Hulu Plus worked as well. Is you XBox wired directly to you AEBS or is it wireless?

    How is your TV hooked up?

    EDIT: Check out this thread: The new AEBS, UPnP and Xbox 360/PS3 and see if there is anything in there that can aid you. A Google search for AEBS UPnP turned up a lot of results.
     
  6. thread starter macrumors member

    Joined:
    Aug 21, 2007
    Location:
    New Orleans
    #6
    Thanks, I will definitely go read that now.

    But to answer your questions: the 360 is connected wirelessly to the AEBS, as is the HDTV (a Vizio HDTV with built-in streaming apps like Netflix, Hulu, Vudu, and Amazon Video on Demand-I assume they all use differing ports, etc).
     
  7. Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #7
    I'm quite confident that all those streaming services use the standard port 80 for their traffic which is the general web browser/Internet port. They may use port 443 for authentication/activation. 443 is the SSL or HTTPS port.

    I really don't think you need any port forwarding for this. Do you have NAT turned on?

    Here are my NAT settings and they're all default.

    [​IMG]

    [​IMG]
     
  8. thread starter macrumors member

    Joined:
    Aug 21, 2007
    Location:
    New Orleans
    #8
    I do... Correct me if I'm wrong but I thought the NAT feature was Apple's version of upnp (I forget the name ATM)... Same function, but not compatible with non apple stuff, etc...
     
  9. SandboxGeneral, Jan 10, 2012
    Last edited: Jan 10, 2012

    Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #9
    NAT stands for Network Address Translation. It is an OS agnostic protocol which basically hides your private LAN IP addresses from the public IP addresses. It has nothing to do with Microsoft Windows or Apple OS X or any flavor of Linux etc...

    In it's simpliest form, it will take your private IP, 192.168.50.203 of your computer and translate it into your cable modem's (or whatever) public IP of 69.172.50.7 so that you can browse (surf) the public [Internet] domain.

    Check out this Wiki for a better and more detailed understanding.
     
  10. thread starter macrumors member

    Joined:
    Aug 21, 2007
    Location:
    New Orleans
    #10
    Thanks; actually what I was referring to in the last post was NAT-PNP.
     
  11. SandboxGeneral, Jan 11, 2012
    Last edited: Jan 11, 2012

    Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #11
    Have you gotten anywhere with this yet? Below are my Xbox 360 settings for the wired network. The wired/wireless should have no bearing on the issues you're having. Regardless though, have you tried a wired setup to see if you still get the UPnP error?

    [​IMG]

    [​IMG]

    [​IMG]
     
  12. thread starter macrumors member

    Joined:
    Aug 21, 2007
    Location:
    New Orleans
    #12
    Not really :/

    I tried putting the 360 on a static IP, doing port forwarding for all the ports listed for the 360, and even putting the 360 as the aebu's default host or whatever (the DMZ). Tried both manual and automatic settings on the 360 side.

    The 360 connects to the network and the Internet fine when running the test. But then for the the last test, it always comes back saying that performance will have a problem because NAT type is strict. Even the tip on the 360 says to open a port that is already being forwarded to it. Weird.

    I can do basic Internet stuff on it, so I guess that's okay... But I have a feeling some XBL stuff won't work right, like multiplayer, live chat, etc. And I've noticed some random disconnections from XBL while playing games.

    Weird huh?
     
  13. macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #13
    Santa brought the kids a new Xbox 360 for Xmas. I just plugged it in and then selected connect to network, entered the ssid of my AEBS, entered my password (using WPA2 Personal), and selected connect. I ma having no issues and it is connected wirelessly. I stream Netflix, and have updated several times and down loaded games and add-ons without any issue. It has been connected and not having any issues with my AEBS from the get go. I hope you get it figured out.
     
  14. macrumors newbie

    Joined:
    May 18, 2007
    Location:
    Pennsylvania
    #14
    Did anyone figure this out? I seem to be having similar issues on my Playstation 3 as well. Connects fine, but when trying to play online games, I will sometimes lose the connection or there is clipping. I also have my NAT Port Mapping Protocol enabled as well in my Airport Extreme...
     
  15. ea9
    macrumors regular

    Joined:
    Mar 14, 2011
    #15
    Probably a stupid post... but it has helped me in the past and sometimes we ignore the obvious.

    Did you try to unplug your x360 and TV ? If you're using a USB adapter unplug that too. A few times it fixed my 360's networking problems before and after the AEBS. The apps on my Sony TV work fine btw.

    Good luck
     
  16. macrumors member

    eatmyjustice

    Joined:
    Mar 24, 2008
    Location:
    Indiana, USA
    #16
    I wish I had researched this sooner. I have APBE arriving tomorrow... We 4 360's and I've ran into MS's implementation of UPnP in the past. Many popular games require it for full online functionality. You can get around it by using a DMZ, but some routers only let you place a single host in the DMZ.... Will the APBE allow multiple hosts?
     
  17. macrumors 6502a

    Prime85

    Joined:
    Mar 1, 2012
    #17
    I know this is an old post but if anyone has this problem in the future i have figured it out.

    First create a static IP for you xbox by going to the network tab in Airport Utility and adding your Xbox mac Address to DHCP Reservations.

    Then follow these directions from Apple

    http://support.apple.com/kb/PH5103?viewlocale=en_US&locale=en_US

    Which basically says go to Network Options at the bottom of the network tab, Check Enable NAT port Mapping Protocol, then add your xbox IP that you created into the Enable default host box.
     

Share This Page