airport extreme networking mac + pc

Discussion in 'Macintosh Computers' started by jadren0, Feb 20, 2004.

  1. jadren0 macrumors newbie

    Joined:
    Nov 4, 2003
    #1
    This may have been covered, but I haven't found it. I am confused as I am a newbie to home networking.
    I have an AE connected to a cable modem. My PB is connected to the internet via Airport, my pc (which I need for work reasons etc etc) is connected to the base station by ethernet cable. Both machines connect fine to the internet. However, I am having trouble setting up a network, or getting the two computers to 'see' each other. Can anyone give me, or point me to, detailed information about setting up a home network. I am using Panther on the PB and XP on the pc.
    Thanks. Best wishes to all.
    J
     
  2. LimeiBook86 macrumors 604

    LimeiBook86

    Joined:
    May 4, 2002
    Location:
    Go Vegan
    #2
    Well first check this.

    Make sure both of your computers have sharing turned on.

    On the Mac: Go to System Prefrences > Sharing and click the "Services" tab then make sure "Personal File Sharing" and "Windows File Sharing'' are checked. Then close the System Prefrences and your set.

    On the PC: I am not sure about in Windows XP, but I think you have to right-click on your volume you want to share (The C: drive I guess) and click on "Properties" In the Properties window poke around and there should be something about "Sharing" or sharing volumes.

    Now on the Mac go to the "Go" menu in the Finder and click on "Connect to Server..." Click the Browse button and hopefully you will see your PC.

    It's not much but I hope I helped you.

    Also make sure your ethernet cable from the PC isn't in the wrong port on the AirPort...I know it sounds dumb but I'm just checking.

    :D
    -limey
     
  3. varmit macrumors 68000

    varmit

    Joined:
    Aug 5, 2003
    #3
    getting started

    You can start by turning on file sharing on the Mac. Open up System Preferences, click Sharing (should be the third line down on the right), check off Windows Sharing. There, the Mac is ready for the windows computer to connect to get files. You can go ahead and see if worked by going to your pc, and open up the network. If your network is not on your desktop, I believe I am telling the correct directions on how to get to the network. To do that, click Start, Control Panel, then click on the Network. When that opens, on the left click show Entire network, the Mac should be in there.

    Now if you want the network icon on your PCs desktop, right click the desktop, choose properties, then under the Desktop tab, you can check off to show the icons like My Computer, Network, My Documents, and IE. Check what you want to show.

    Ok, once you do this, I'll tell you, if I can remember correctly, how to share a folder on your PC with the Mac.
     
  4. jadren0 thread starter macrumors newbie

    Joined:
    Nov 4, 2003
    #4
    thanks for the replies guys. I have tried what you say, but so far no dice. In Windows there is no sign of the Mac. I have even tried accessing the server via 'run' (\\10***). I am wondering whether the problem is with the workgroups settings on both machines. The Airport network/workgroup has the same name as the windows workgroup, but that hasn't helped.
    I have done as you suggested to share the Mac files.
    I will keep trying. Let me know if you have any ideas, and thanks again.
    j
     
  5. varmit macrumors 68000

    varmit

    Joined:
    Aug 5, 2003
    #5
    do the \\10******

    when you check the Windows Sharing, it tells you how to access the Mac from a PC. then do that in IE on the PC.
     
  6. abhishekit macrumors 65816

    abhishekit

    Joined:
    Nov 6, 2003
    Location:
    akron , ohio
    #6
    ok..there is a sticky about the same topic in general apple tech discussion..check that out..
    and if you are not able to see your mac on xp...there is something in the nework setting called 'find computers near me'..it will definitely find your mac if windows sharing is on or otherwise.
    then when u click on it, it wd ask user name and password..
    and from mac, its really simple using smb..as other people have pointed out..open finder , hit cmd+k
    write
    smb://name of the workgroup;username@computername

    username and computer name are regarding the widnows comp.
    best of luck
    cheers
     
  7. jadren0 thread starter macrumors newbie

    Joined:
    Nov 4, 2003
    #7
    Thanks again everybody, but it's still not happening.
    I have set up the Airport network using the PB. I have also set up a 'home network' on the PC and used the same name for both. The internet works on both machines, but they can't see each other.
    I have set up personal and windows sharing on the Mac and shared certain folders on the PC.
    I'll keep trying things and let you know... My natural tendency is to think it's the PC's fault, but I can't get things working from either side.
     
  8. jadren0 thread starter macrumors newbie

    Joined:
    Nov 4, 2003
    #8
    Thanks abhishekit - the sticky is very informative.
    However, I have tried everything suggested and I'm still not able to connect the two computers.
    The pc seems to be able to ping the PB at it's (fake 192.*****) IP address, but can't see it in networking. The PB can't ping the pc.
    Arg.
     
  9. James Craner macrumors 68000

    James Craner

    Joined:
    Sep 13, 2002
    Location:
    Bristol, UK
    #9
    On the network preferences pane on the Powerbook. In show dropdown select Airport and make sure that the 'Allow this computer to create networks' check box is turned off.

    Also check in the Airport Admin Utility that under Network that the distribute IP Address is also checked off as well.

    If you have enabled file sharing on the Mac and PC as other users have suggested you should now see each other.
     
  10. abhishekit macrumors 65816

    abhishekit

    Joined:
    Nov 6, 2003
    Location:
    akron , ohio
    #10
    ok try this. open the terminal on the pb. it would be under finder-application-utilities
    you will get a window and a prompt at the third line. write "findsmb" without quotes at the prompt and hit enter
    now it should display the name, ip and workgroup of your windows machine.
    now open finder, press cmd+k
    under server address write
    smb://workgroup;username@computer_name
    it would ask you for password and should connect, unless you dont have a shared folder on the windows system.
    Now the workgroup and computer name , you fill exactly as it shows when u do findsmb.
    hope it helps..sorry if i was repetetive
     
  11. jadren0 thread starter macrumors newbie

    Joined:
    Nov 4, 2003
    #11
    Thanks again for your help.
    James - when I do as you advise, all that happens is that I can't share the internet connection. I really don't know much about networking so please tell me if I'm missing something.
     
  12. jadren0 thread starter macrumors newbie

    Joined:
    Nov 4, 2003
    #12
    abhishekit - so far the pc doesn't show in Terminal on the PB.
    Thanks anyway...
     
  13. James Craner macrumors 68000

    James Craner

    Joined:
    Sep 13, 2002
    Location:
    Bristol, UK
    #13
    Oops sorry I thought you were using a router, I can see from you original post that you are just connecting to a cable modem. In the Airport Admin Console in Network turn Distribute IP address back on. I think you will find that should now work. Leave 'Allow this computer to create networks' check box is turned off on the Powerbook.
     
  14. jadren0 thread starter macrumors newbie

    Joined:
    Nov 4, 2003
    #14
    Right, the Airport is the router, and is connected to the cable modem.
    I have left 'allow this computer to create networks' unchecked, as you suggest, but still no joy...
    As I said, the windows machine can ping the mac with its (fake) ip address, but can't find it in any network nor as a server; the mac can't ping the pc...
    I'll keep trying things out...
     
  15. jadren0 thread starter macrumors newbie

    Joined:
    Nov 4, 2003
    #15
    ok, the Mac not being able to ping the pc was a false problem. I can now ping either machine. However both machines are invisible to each other in terms of networking...
     
  16. abhishekit macrumors 65816

    abhishekit

    Joined:
    Nov 6, 2003
    Location:
    akron , ohio
    #16
    k now try findsmb and finder cmd+k blah blah...
    and make sure windows comp is on..
    i am sorry to be insistent..but i find it really strange that it doesnt show ur windows comp when u do findsmb..
    hope it works this time:p
     
  17. jadren0 thread starter macrumors newbie

    Joined:
    Nov 4, 2003
    #17
    strange indeed, but it's still the case. The computers can ping each other, but they are not showing up in networks or by browsing servers. I am wondering if the pc might not have some networking problem (I should try to get another pc to test this). I was planning to get a wifi card for the pc as well eventually - maybe it will work when I do...
    Thanks everyone.
     
  18. jadren0 thread starter macrumors newbie

    Joined:
    Nov 4, 2003
    #18
    Got it working! Yay!

    As I suspected, the Windows machine was causing the problem. DHCP from the PC was causing some kind of conflict. I set up the IP manually (ie. with the address attributed by the Airport, and with dns to the Airport's attributed IP) and it works!

    This advice should maybe be added to the sticky, since it really was stopping my computers from 'seeing' each other.

    Thank you:
    abhishekit
    varmit
    LimeiBook86
    James
    for all your help.
    We got there in the end...
     
  19. areiter macrumors newbie

    Joined:
    Feb 29, 2004
    #19
    Can you explain what you did because I am having the same problem.

    Thanks
     
  20. mklos macrumors 68000

    mklos

    Joined:
    Dec 4, 2002
    Location:
    My house!
    #20
    They were probably on different subnets!

    From what you said about the manual IP addresses working your PB and your PC were probably on different subnets. You need to be on the same subnet in order for two computers to see each other. An example of a subnet address is 255.255.255.0 or 255.255.0.0. When you gave them similar IP addresses they suddenly became on the same subnet so I'm guess thats why it started working. I could be wrong though. Especially if you used the AirPort as a router. Hmmmm...
     
  21. areiter macrumors newbie

    Joined:
    Feb 29, 2004
    #21
    mklos I just checked my powerbook and my PC and they both say they are on the same subnets, but I still cannot connect the computers.
     
  22. mklos macrumors 68000

    mklos

    Joined:
    Dec 4, 2002
    Location:
    My house!
    #22
    Firewall turned on?

    Does the internet work on both?

    Is the firewall turned on in Mac OS X or in XP? In Mac OS X the firewall is under the Sharing System Preference. In XP I think you right click on your connection and then go to Properties. Somewhere in there is the settings for the firewall.

    On the PC try this...Right Click on My Computer and then go to Map Network Drive. Put in the IP address of the iMac then slash your home directory. (ex. 192.168.100.1/admin) and see if the PC finds it. If your prompted for a password make sure you use the username and passwords from Mac and NOT the PC.

    On the PC side also make sure your sharing a folder. I usually share the My Documents folder. Also I share it as mydocuments, all in one word. Somethings don't like spaces so its good to do that.
     
  23. areiter macrumors newbie

    Joined:
    Feb 29, 2004
    #23
    The firewall was off on both. When I tried the map network drive it PC could not find the mac. Also I have a hard drive shared, not a folder does that make a big difference. When I have itunes running on the PC the mac is able to see the shared music. It is just a very strange problem I guess.
     
  24. encro macrumors 6502

    encro

    Joined:
    May 6, 2002
    Location:
    bendigo.victoria.au
    #24
    I have almost the same problem also.

    I have an AirPort Card in the iMac and a DLink DWL900AP+ connected to the ethernet port on the XP machine.

    My IP's are as follows (all subnet 255.255.255.0):
    iMac: 192.168.0.1
    Airport Card: 192.168.0.49
    P4XP: 192.168.0.2
    DWL900AP+: 192.168.0.50

    Do I need to set the router/gateway on anything to obtain a working connection? WEP/WPA isn't turned on either and is not linked to the internet.

    iTunes can see the other machine via Rendezvous but claims port 3689 is blocked despite the fact the firewall has been turned off to help troubleshoot.

    I try to ping the XP (192.168.0.2) machine from the Mac (192.168.0.1) but it says "Host is down" and same vice versa.

    The damn thing just wont link up :confused:
     
  25. abhishekit macrumors 65816

    abhishekit

    Joined:
    Nov 6, 2003
    Location:
    akron , ohio
    #25
    two questions ...how did u get two separate ip for imac and airport??
    is internet working on any of the two machines?you have just two machines, right?
     

Share This Page