Airport Extreme - VERY slow internet

Discussion in 'Mac Accessories' started by StevenMRoth, Nov 15, 2011.

  1. macrumors newbie

    Nov 15, 2011
    Hurricane, WV
    Hi everyone.

    I'm new to the forums but so far it seems like a great resource for Mac products.

    Recently (last 6 months) I had to replace an old Linksys router. I figured with the quality apple has I would purchase the Airport Extreme router. I have cable internet and the Airport Exteme is set up for wifi for my home.

    Typically there are only 5 different devices things that ever use our internet. We have a MacBook Pro, a Macbook, 2 Iphones, PS3 and a Wii. I live with only two people that utilize the internet; myself and my wife. It affects all the devices not just computers.

    My office is literally 10 feet from my router and my signal is always strong but the loading of webpages is painful and streaming youtube videos or netflix on the Wii is impossible.

    I was in a hotel last night and ran a on it to see what the internet speeds were.

    In the hotel internet I had the following:

    Download: 31.36 Mb/s
    Upload: 3.20 Mb/s
    Ping: 27ms

    At home which should be a better connection I had the following:

    Download: 0.36 Mb/s
    Upload: 0.98 Mb/s
    Ping: 144 ms

    I have tried the 5Ghz channel, I have tried changing channels which seems to help sometimes but I think it is just wishful thinking.

    I call apple they say it is interference and even sent me a new unit after I went through the standard hard reboots. Letting the modem and APE recycle and power through everything.

    I'm pretty much at a loss. I had the old one and they sent me a new one and the exact same thing is happening so it has to be something with the set up. Any ideas.

    Thanks in advance for the help.

  2. macrumors 6502a


    Jun 1, 2007
    Have you connected a Mac directly to the cable modem and run speedtest for comparison?
    Get iStumbler and see if there are interfering stations nearby.
  3. mmomega, Nov 16, 2011
    Last edited: Nov 16, 2011

    macrumors demi-god


    Dec 30, 2009
    DFW, TX
    I just did a speedtest and got this number on my macbook air in the living room which uses an Airport Express wirelessly extending from the Airport Extreme in the office.
    I get 30+ if I go into the office and pull straight from the base station.
    Not sure what to tell ya.

    Mine auto switched to the 5GHz channel once I went into the office but that first run was still on 2.4 which should easily be way higher than what you're getting. I have had times where my home internet for no reason would drop down to almost nill but it would not stay that way for long.
    Have you tried unplugging your modem and router for a few seconds along with turning off your computer. then plug everything back in just to refresh all the connections?
    Used to have to do this at my sisters house at least once a day with more than 2 computers on wireless, it would come to a screeching halt until you reset the modem. Then it would go back to normal for 3-4 hours.

Share This Page