Airport Extreme: WPA connection disconnects after sleep

Discussion in 'Mac Apps and Mac App Store' started by tonycpsu, Apr 9, 2004.

  1. tonycpsu macrumors member

    Mar 24, 2004
    I'm using WPA encryption on my Airport Extreme via a Linksys WRT54G. Everything works great, except when my Powerbook wakes up from sleeping, the connection is lost, and doesn't reconnect. To re-establish the connection, I have to select "Turn Airport Off" and then "Turn Airport On" from the Airport extra, then select my network from the menu. It doesn't seem to be a question of forgetting the key, because it doesn't ask me for the key again when I do this.

    So, (a) has anyone seen this behavior and (b) is there any known fix? I saw a couple other posts in a Google search referring to this behavior, but they were older posts, and didn't have any answers.

    This is on OS X 10.3.3 BTW with all the most recent updates.
  2. jywv8 macrumors 6502

    Jan 11, 2003
    I have the same problem on my G5 running 10.3.3, only I don't have to turn airport off and on. I just have to reselect my network from the menu.

    I also consistently lose my smb connection to my Win box. That is more annoying, personally.
  3. nargot macrumors regular

    Jan 29, 2004
    When you put a computer to sleep, it generally shuts all network activity. Just set your airport connection to autoconnect to the network. mine connects to my unbroadcasted, encrypted network whenever it is on.
  4. tonycpsu thread starter macrumors member

    Mar 24, 2004
    I do have it set up to autoconnect, and the network shows up as connected in the airport extra (it's got a checkmark next to the network name.) But the airport signal meter is empty. If I change from WPA to WEP, it autoconnects correctly. But when I use WPA, I need to turn the airport off and on (and then select the network name again) to have it reconnect. Are you using WEP or WPA when you do this?
  5. MoparShaha macrumors 68000


    May 15, 2003
    San Francisco
    My PowerBook did this when I upgraded my access point to WPA. The condition lasted about a day, then went away on its own. I don't know what fixed it. Sorry I can't be more specific.
  6. nargot macrumors regular

    Jan 29, 2004
    I'm using WEP, 128 bit encryption and it works fine.
  7. tonycpsu thread starter macrumors member

    Mar 24, 2004
    Okay, yeah... So based on what people have said here, it seems WEP reconnects properly, but WPA does not. That's a shame, because WPA is a lot more secure than WEP. I guess for now I'll switch to WEP (which is probably "secure enough") and hope Apple fixes WPA someday.
  8. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    No, wait, I have an AEBS which was running its internal sw version 5.3 up till a few minutes ago, and an iBook G4. I am using WPA personal. For me, when I wake it up, it takes several seconds to renegotiate the connection (~5-7 seconds after opening the lid) but it reconnects automatically almost always. Every once in a great while I have to do the "click on my network in the menu bar airport menu" thing again, like jywv8 described, but that is only very rarely.
  9. tonycpsu thread starter macrumors member

    Mar 24, 2004
    Hm, mine never renegotiates successfully... Always have to do the click-on-the-network trick. Then again, I'm using a Linksys router rather than an AEBS. Maybe that's the difference (and probably a reason for Apple NOT to fix the bug.)
  10. Guinness 70 macrumors newbie

    Nov 11, 2007
    THis happens on my Mini

    This same problem started when I upgraded to leopard. Whenever it sleeps it disconnects. I don't use any encryption and it still does it. My G5 iMac does not have the same problem. I upgraded both at the same time. What a pain. I tried the "leave HDD on" trick, but it still will not reconnect after sleeping. I have to "turn off" the Airport after sleeping even though it is off and then turn on again and it will connect.

    Seems like certain hardware has the problem.
  11. Ranza macrumors newbie

    May 2, 2008
    Sydney, Australia
    A Express Disconnected after wake, every time!

    Hey all,

    I figured out the solution. I have only had this problem for the last few days since changing my WPA2 password.

    My solution was to do the following;

    1. Disconnect from my network.

    2. Delete the keychain for my Airport Express from my Keychain Access App found in the Utility folder.

    3. Reconnect to my network and enter the password and save to keychain.

    4. Delete and re-enter my network as the only preferred network in System Preferences under network settings. ( I don't think step 4 is necessary.)

    All fixed! Hope this helps!!
  12. Mt.Everest macrumors newbie

    Feb 8, 2004
    Wow thanks! Ive been searching for this for a while and this was the only fix that worked! Much thanks!
  13. spudwaffle macrumors newbie

    Oct 20, 2010

    This has been a minor annoyance for me ever since I switched my SSID broadcast off (made the network hidden).

    The fix works perfectly.
  14. Puppybasher macrumors newbie

    Mar 14, 2010
    Sorry to reopen this topic but I'm experiencing this problem and the solution given in this topic does not seem te help :(
    The weird thing is that it only started happening a while ago. When I did a fresh install everything working as intended and suddenly this started happening, no idea why.

Share This Page