Airport joining the wrong network!!! WHY???

Discussion in 'Mac Apps and Mac App Store' started by d_saum, Nov 5, 2005.

  1. d_saum macrumors 6502

    d_saum

    Joined:
    Jun 14, 2005
    Location:
    NC
    #1
    Please please please... someone help me out!!!! For some reason, everytime my iBook is powered on or wakes from sleeping, it ALWAYS jumps on my neighbors wireless network. I dont understand why. I have the "much" stronger signal, and I have it as my preferred network. There's GOT to be a way to tell my iBook to never join that network right???

    Bonus question: At work there is an open network that has the same name as my neighbors (linksys), and I'd still like to be able to jump on that. Also, I sometimes wardrive so I still want to be able to join open networks and dont want to rule out any network named "Linksys".

    Thanks!
     
  2. Jedi128 macrumors 6502

    Joined:
    Jul 7, 2005
    Location:
    New York, NY
    #2
    Funny I should come across this post becuase I just fixed this problem on my iMac. I was trying to print to my printer connected to my Airport Express, but then noticed that my iMac was connected to my neighbor's network. So then I went in and made sure it won't ever connect to it again...

    (by the way I'm running Tiger so these might a little different if you have a different version of X...)

    Anyway what I did was go to System Pref. and go to Network. Then Configure Airport. Then look up your preffered networks and if the neighbor's network is in there remove it from the list. Then click on the Options button in lower left corner. Be sure to set "If no recent networks are found:" to "Ask before joining an open network." The most important step is to makesure that "Remember any networks this computer has joined" is unchecked. This should prevent your computer from automatically joining any networks you don't want it to. And yes you will still beable to join the network but you must first select it and it might ask you if you really want to join(or for a password if it is password protected).

    Hope this helps!! Tell me if you have any questions or problems....
     
  3. EricBrian macrumors 6502a

    EricBrian

    Joined:
    Jul 30, 2005
    #3
    Cool. I wondered about this too. Finally, I won't connect to my neighbors network anymore. :)
     
  4. ITASOR macrumors 601

    ITASOR

    Joined:
    Mar 20, 2005
    Location:
    Oneida, NY
    #4
    I wish my neighbors has wireless I could mooch from...lol. They're all probably on mine right now. :eek:
     
  5. d_saum thread starter macrumors 6502

    d_saum

    Joined:
    Jun 14, 2005
    Location:
    NC
    #5
    sweet! Thanks for the help! I've poked around in the system pref's before for the airport card, but I guess I missed the "remember any networks joined" thing. I also changed the drop down options to keep trying for the preferred network. Thanks again! ;)
     
  6. andyrain macrumors newbie

    Joined:
    Sep 14, 2006
    #6
    Thank you!

    I've been having the same problem and am happy to have a fix! It worked! Just one of those pesky things that had been driving me crazy..... Thanks!
     
  7. MacMe66 macrumors newbie

    Joined:
    May 21, 2007
    #7
    not a solution for my situation

    i work between 2 networks / need to connect sometimes to one, sometimes to the other. Their WiFi access points stand only 10 meters appart in different rooms, their SSID's are not broadcasted and i'm using encrypted WEP on one and WEB 128bit on the other router and Mac-adress limited access. Configured 2 locations in the OSX10.5.2 network prefs with the intend to switch off airport connection, change location and switch on again. No luck on switching to the right network!

    Connection sometimes switches from one to the other network without my interaction; more commonly after macbook went to sleep. Settings "prefered networks" don't work , network dragged down appear on top of list again without my interaction.

    I'd love to have this working!
     
  8. Sorcerer8605 macrumors newbie

    Joined:
    May 22, 2008
    #8
    Yeah, this has been a big problem since Leopard came out, and they haven't fixed it; maybe they never will. In Tiger, my preferred networks stayed put. In Leopard, when I disconnect from my number two network (a campus network), and then go to my room, where my computer should pick up my AirPort, the computer connects back to the campus WIFI. When I go to preferred networks, campus WIFI is at the top, and mine is second. It's very frustrating. I just want to PREFER my AirPort whenever it's available. Is that so hard, Apple? It didn't seem to be so hard in Tiger!
     

Share This Page