Airport link unstable

Discussion in 'MacBook Pro' started by RCharles, Mar 27, 2007.

  1. RCharles macrumors newbie

    Joined:
    Mar 27, 2007
    Location:
    PA
    #1
    I have a new MacBook Pro running OS X 10.4.9 and I'm using Airport to connect with a Netgear router that has WEB security enabled. Router and cable modem are on a loft overlooking room with the MacBook. There are no new software updates for my versions of OS or Airport.

    the connection is established and works fine most of the time with full signal level. But the link drops at random times even when I'm working on the MacBook. I'll notice FireFox going noplace and then see the airport icon is showing no signal. I just tell airport to re-connect, provide the keychain(?) password and it's up and running.

    How do I configure Airport to stay up permanently when the MacBook is up and running?

    How can I configure Airport to not require the keychain password just to restart?

    BTW, this same router supports a windows laptop, which stays up for hours. The airport problem occurs when the windows laptop is up or down.

    Also, I called Apple Support to get help since I'm still under the 90 day warranty; the technician claimed the router was for a windows computer and I should get the Apple Airport router. When I protested that these are industry standard devices he said to wait while he went for help; I hung up after waiting for ten minutes (on speaker phone).

    thanks for any help.

    Ray
     
  2. ebouwman macrumors 6502a

    Joined:
    Jan 5, 2007
    Location:
    Canada
    #2
    what you should do is go to sys prefs > network > configure > options
    then uncheck the box that says require admin password to change networks.
    That should make it so that you don't have to enter the password each time

    is it maybe that your router is set to automatically choose a channel and it switches randomly? Not sure if that can really happen but it's worth checking.
     

    Attached Files:

  3. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #3
    I have had this problem with windows machines connecting to a wireless DLink router but not with the Apples in my house.

    However to get around this intermittent connection problem I did three things.

    1. Set the broadcast channel of my router to 10. Since on automatic it selected 6 like every other router in my neighborhood causing interference, you can use any channel just avoid 6 since most people never bother changing their broadcast channel from this default.

    2. Assigned static IP addresses to all devices on my network.

    3. Manually configured TCP/IP settings on the devices to match their assigned IP addresses.

    After doing this I get nearly immediate connections that are quite stable. I would also upgrade your router to it's latest firmware as this will normally decrease connection problems, I'm not sure how Netgear is about this but DLinks are horrible products until you update their firmware.
     
  4. ebouwman macrumors 6502a

    Joined:
    Jan 5, 2007
    Location:
    Canada
    #4
    Use a program called iStumbler (free) http://www.istumbler.net/ and then you can see what channels peoples routers are using and then change it to some other channel.
     

Share This Page