airport not joining default network

Discussion in 'General Mac Discussion' started by howard, Nov 2, 2004.

  1. howard macrumors 68020

    howard

    Joined:
    Nov 18, 2002
    #1
    for some reason my airport is joining on another network instead of mine. I went to the system preferences under network and configured the airport settings to join my specific network by default, restarted my computer and it just joins the other network... anyone know whats going on or how to fix this?

    thanks
     
  2. emw macrumors G4

    emw

    Joined:
    Aug 2, 2004
    #2
    I am assuming that you can then go to your network and join it and that there are no problems doing that?

    If so, you might want to try deleting your preferences (com.apple.airport.plist) and do it again. This behavior doesn't sound normal.
     
  3. howard thread starter macrumors 68020

    howard

    Joined:
    Nov 18, 2002
    #3
    yes i can easily switch back to my network, but whenever my computer goes to sleep i wake it up, find out the internet isn't working, realize its on that other network then change it over...
     
  4. emw macrumors G4

    emw

    Joined:
    Aug 2, 2004
    #4
    Okay, did you try deleting the prefs file?

    Also, is your network broadcasting its SSID? If not, then automatically joining it by name won't work as far as I know.
     
  5. howard thread starter macrumors 68020

    howard

    Joined:
    Nov 18, 2002
    #5
    i just tried deleting the prefs, still doesn't work right.

    i don't know what SSID is but i can tell you that there are always between 3-6 networks available nearby that i can join including mine and this has never happened until this specific network started showing up.
     
  6. emw macrumors G4

    emw

    Joined:
    Aug 2, 2004
    #6
    Even more odd. So you're saying that once this new guy showed up with his network, your Airport dumped you? Did you log onto it once to see what it was? If so, check your Keychain Access utility for a password and delete it, which might clear it up.

    You could also try changing the name of your network and then reset your "by default connect to:" setting.

    Oh, SSID is the network name that shows up when you go to select a network from the Airport drop-down list.
     

Share This Page