Airport slowing down Powerbook?

Discussion in 'PowerPC Macs' started by Ryvius, Nov 27, 2005.

  1. macrumors member

    Joined:
    May 4, 2004
    #1
    Here's a new one I can't find any info on:

    More than 6 times in the last two days, Airport has randomly severed connection on my latest rev 15" Powerbook. It can't detect my network, it can't connect or detect my neighbor's network. It also causes the machine to slow down and for the cursor to be very unresponsive using USB mouse and the trackpad.

    As soon as I disable Airport the computer speeds up again. As soon as I re-enable it it slows back down and cannot access the network.

    Only by rebooting does this solve the problem.

    Anyone have any ideas on how to fix it?

    -- Ryvius
     
  2. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Are you running any P2P or bit-torrent apps? I've heard of this happening before on the aluminium PowerBooks and there hasn't been a single fix AFAIK. Maybe try ditching your airport preferences (search for AirPort and PLIST) and perhaps try getting your base station to broadcast on a different channel. :)
     
  3. thread starter macrumors member

    Joined:
    May 4, 2004
    #3
    No file sharing programs up. Just happens randomly during normal usage.
     
  4. macrumors 603

    OutThere

    Joined:
    Dec 19, 2002
    Location:
    NYC
    #4
    If you're using a non-Apple router you should get the latest Airport update...it came out a week or two ago (I think) and is supposed to fix some stability issues with non-Apple parts.
     

Share This Page