Airport Won't Automatically Reconnect After Sleep

Discussion in 'macOS' started by Nastard, May 8, 2005.

  1. Nastard macrumors newbie

    Joined:
    Jan 6, 2004
    Location:
    Denver, CO
    #1
    Since I upgraded to Tiger, my PowerBook doesn't automatically reconnect to wireless when I wake it up. It's the only real flaw I've noticed, but it's irritating. I submitted a bug report to Apple, but I was hoping someone had a fix or a workaround.
     
  2. DXoverDY macrumors 6502a

    Joined:
    Apr 19, 2005
    #2
    does it find the network, just throws you a message asking if you'd like to connect to a network? make sure it's in your "prefered networks" list. open up network preferences in system preferences and add the SSID (network name) to the prefered list.
     
  3. NCTRNL macrumors regular

    Joined:
    Aug 17, 2004
    Location:
    Kansas City
    #3
    It sounds like you're having the same problem that I was having when I was using Panther. I went to the Mac Genius at the Apple Store near here and he helped me. You have to clear your preferences out and restart the computer and it should work fine after that. One thing you can do to make sure it is having the same problem is after it wakes back up and won't reconnect, go to System Preferences and go to Network. If it shows a yellow icon for Airport, that means it is connected but can't get an IP address. GO to your Mac HD > Library > Preferences > SystemConfiguration and clear out the preferences that have to do with Airport, Network, and the one that is just called Preferences. There are 3 that you need to delete and then restart... That fixed my problem and since I upgraded to Tiger, I haven't had anymore problems.
     
  4. Nastard thread starter macrumors newbie

    Joined:
    Jan 6, 2004
    Location:
    Denver, CO
    #4
    I can click the Airport icon at the top and select my network and it works fine again. I tried blowing out the .plist and restarting, but that didn't fix it.

    I submitted it as a bug to the Apple dev team, though, and after sending info back and forth, they say they're working on a fix for it.

    I'm hoping it's fixed in 10.4.1
     

Share This Page