AirPrint & Windows Shared Printer

Discussion in 'iPad Tips, Help and Troubleshooting' started by Sky Blue, Sep 29, 2010.

  1. Guest

    Sky Blue

    Joined:
    Jan 8, 2005
    #1
    I've installed 10.6.5 on a test Mac to test out Airprint and it works fine. I've installed iTunes 10.1 on Windows and the printer does show up on my iPad, but it has a lock next to it and asks me for a password every time I print. Seems like it's looking for a local admin password.

    I'm not especially proficient in Windows... how do I set the printer to print without requiring a password? I've tried allowing guests to print, giving the everyone group full access, but it still asks me for a password.
     
  2. macrumors 6502a

    Joined:
    Jul 10, 2008
    #2
    Did you try sharing the printer? Right click > Share. You might need to reboot all devices after doing so.
     
  3. thread starter Guest

    Sky Blue

    Joined:
    Jan 8, 2005
    #3
    Yes, the printer is being shared. Otherwise it would not show up on the iPad.
     
  4. macrumors 6502

    Joined:
    Jun 16, 2009
    #4
    you are right. but maybe their are preferences in sharing that require a password. i don't know windows anymore that well either but on mac sharing you can make it so you need a password.
     
  5. macrumors regular

    jwilson25

    Joined:
    Aug 25, 2009
    #5
    What version of Windows are you using? I know in Windows 7, the default for sharing is to require a username/password, but you can turn that off.
     
  6. thread starter Guest

    Sky Blue

    Joined:
    Jan 8, 2005
    #6
    I've looked, I don't see anything. I've set the Everyone group to have full access, but it still asks for a username/password.

    Using XP SP3.
     
  7. macrumors 68040

    Joined:
    Nov 6, 2008
    Location:
    On my iPad
    #7
    Did a google search for you and got this: "The problem is that Windows XP will not allow access to the printer without a legitimate user account and password. If you are trying to connect to a shared folder over the network, you will get a dialog box which allows you to enter this information, but this will not work for printing".
     
  8. macrumors 6502a

    Joined:
    Jul 10, 2008
    #8
    I remember this being an issue with sharing a printer with something else before now.

    Enable the guest account on the Windows box. Reboot and then I think you're clear. I'm pretty sure that was the way around my issue.
     
  9. thread starter Guest

    Sky Blue

    Joined:
    Jan 8, 2005
    #9
    I was googling for a solution and this thread was the third choice. :/
     
  10. macrumors regular

    Joined:
    Sep 23, 2007
    #10
    I have a printer shared out on my vista machine and itunes 10.1 open with airprint checked. My ipad can not see the printer. is there any thing else i need to do in itunes to show this printer?
     
  11. macrumors newbie

    Joined:
    Jun 25, 2010
    #11
    I can confirm if you enable the Guest user account on Windows 7 the padlock symbol next to the attached printer vanishes from your iDevice when selecting the printer and username and password are not required.

    F
     
  12. macrumors member

    Joined:
    Oct 10, 2007
    Location:
    Tucson, AZ
    #12
    Yes, I just turned on Guest on my wife's windows 7 machine.
    It printed on either printer:

    A Brother 2070N and a Canon MP 970.

    Now if Apple would get off the pot and get out 10.6.5 for my iMac and MacBook!
     
  13. macrumors newbie

    Joined:
    Nov 14, 2010
    #13
    Make sure both, the system and iOS device are within the same IP range and subnet. One can not be connected to one router while the second is on a wireless router on another room.

    I hope that helps.
     
  14. macrumors member

    Joined:
    Nov 22, 2010
    Location:
    Geraldton, Western Australia
    #14
  15. macrumors newbie

    Joined:
    Aug 31, 2011
    #15
    XP network settings

    If you are having trouble printing to XP, check the Properties of the Wireless Connection. Make sure File and Printer Sharing for Microsoft Networks is checked. It should be set to Service.
     

Share This Page