ALL my browsers keep crashing.

Discussion in 'OS X' started by Gamble, Nov 24, 2008.

  1. macrumors member

    Joined:
    Apr 3, 2008
    #1
    I have tried 3 of them. Firefox, Flock and Safari. All seem to crash after 3 minutes or so but can last up to 10. It started happening when i was watching some videos on Youtube and then when i went to go and watch another it wouldnt load it up. And since then i have came across this problem. I tried phoning Apple but at £35 just to fix this seems a bit steep :)

    So does anyone have any ideas?

    :apple:
     
  2. macrumors 6502

    sOwL

    Joined:
    Sep 25, 2007
    Location:
    Athens, Greece
    #2
    From what i understand, those apps dont "crash", its just that the pages wont load.. right? This can be related with your internet settings (proxy etc), but if those apps do actually crash, its very very confusing that all 3 browsers crash, and this could be related with other factors. So, explain a little bit better so we can help
     
  3. Moderator emeritus

    ergdegdeg

    Joined:
    Oct 13, 2007
    Location:
    Nebraska
    #3
    Two things, if the pages aren't loading - as opposed to the apps crashing:
    Do you use torrents / other mass downloading? Some Internet Providers will slow down your connection if you do.

    Try OpenDNS and see if it helps (it did for me)
     
  4. thread starter macrumors member

    Joined:
    Apr 3, 2008
    #4
    Yea, they do crash sorry its just i noticed that with video's not loading on youtube. The whole page will load bar the video.

    When i say crash it will come up with "Flock, Firefox, Safari has unexpectedly crashed" then gives you the option to report or ignore.

    Tbh i really have no idea whats causing these crashes. And is getting quite frustrating ^^

    Note** Pages load fine :) Just any pages with a youtube video will load everything else except the video.
     
  5. macrumors member

    Joined:
    Jan 21, 2008
    #5
    Re-install your Flash player.
     
  6. macrumors 6502

    sOwL

    Joined:
    Sep 25, 2007
    Location:
    Athens, Greece
    #6
    ah, that could be your problem, nice thought dcubed20. Anyway, have u checked the crash log to see what caused the crash? You could post it here for folks to help you
     
  7. thread starter macrumors member

    Joined:
    Apr 3, 2008
    #7
    Something so simple >.< Well i re-installed it and youtube video's now work lets hope its sorts the browser issues :D

    Thanks dcubed :)
     

Share This Page