Amiga emulation so very slow

Discussion in 'Games' started by Palad1, Jun 9, 2006.

  1. Palad1 macrumors 6502a

    Palad1

    Joined:
    Feb 24, 2004
    Location:
    London, UK
    #1
    Hello,

    I've transfered my amiga collection from a crappy dell to a wonderful PowerBook G4 SD (2gigs RAM, yadda yadda) and I'm appalled by the speed of the thing.

    My amiga roms are legit (kickstart 1.3, wish I had extracted it myself from my dusting amiga 500 but the thing won't boot :( )

    I'm using e-uae plus hi-toro, default settings, and perfs are horrible.
    Turrican for example, gets about 4 fps....

    Help pleeease :)

    Thanks,
    Palad1 and his 'old' G4 bender
    Happy campers

    ps: I predict a post from RaggedJimmy very soon ;)
     
  2. Dagless macrumors Core

    Dagless

    Joined:
    Jan 18, 2005
    Location:
    Fighting to stay in the EU
    #2
    Hello! ;)

    Amiga emulation is terrible under OSX. Even worse on the PSP. It's not a fast emulator under any system other than PC. I just know I've had terrible speeds under the OSX version of UAE. I don't have an answer, but add me to the list of people who would like a faster UAE. Or alternatively dust off my Amiga and stick the front panel back to the case :D
     
  3. Palad1 thread starter macrumors 6502a

    Palad1

    Joined:
    Feb 24, 2004
    Location:
    London, UK
    #3
    Found a fix to my speed problem using Hi-Toro: emulate a full ECS and set the proc to 68020 / 2megs ram / 2megs fast ram / cycle exact

    Weeee!
     

Share This Page