Annoying message: Safari wants to use keychain "login"!

Discussion in 'OS X' started by ziggyonice, Jan 5, 2009.

  1. macrumors 68020


    Mar 12, 2006
    Rural America
    I work for a company that has several Macs available for customers' use. These are basically demo-machines that they can play with, and at the end of each day, the machines are wiped and rebooted.

    The way we do this is simple: the machines auto-login to the Guest account, which will wipe the account at the end of the day. Well, getting a few new Macs in this week, I simply copied over the entire Guest user account to the new machines to avoid reloading all the demo content, preferences, etc. And truthfully, the machines have been working great.

    Except one thing. The computer keeps giving me that annoying message that says "Safari (or Finder, or System Preferences, or anything!) wants to use keychain 'login'". And asks for the login keychain password. Well here's the thing: the Guest accounts don't have passwords!

    So I looked up a little bit on this topic, and did things like... Went to "Keychain List" in the Edit menu of Keychain Access, and deleted both the "login" and "system" keychains. No help. I went to Preferences in Keychain Access and said "Reset My Keychain". When doing this, however, it asks for the new password for the login keychain.

    The problem with this is that I cannot leave the field blank! The Guest account doesn't have a password, so how am I supposed to not create a password?

    Does anybody have any ideas? Thanks.
  2. macrumors 68000


    Oct 15, 2007
    This sounds like it could be a simple case of needing to open Disk Utility and repair disk permissions.
  3. macrumors newbie

    Ward Clark

    Feb 27, 2010
    Repair Permissions didn't help

    I've been supporting six iMacs (10.5.8) at my new local public library, which opened late October 2009. Starting about a week ago, four of the iMacs have developed precisely the same Safari sickness ziggyonice described.

    Repair Permissions on one of the problem iMacs made no change.

    So far, Google has not revealed a cure for this annoying problem. I'm anxious to fix it because it's become bad PR for Macs in what used to be a PC-only library.

    -- Ward
  4. macrumors 68000


    Mar 28, 2006
    West Plains, MO USA Earth
  5. macrumors newbie

    Ward Clark

    Feb 27, 2010
    Mea culpa

    I just returned from the library. Armed with a little more knowledge about Guest accounts, I fixed the problem that I created a couple of weeks ago. Here's my short story with a happy ending:

    The six iMacs at my wonderful Townsend (MA) Public Library have Guest accounts so that each user session begins with a fresh account. When the out-of-the-box Guest account proved to be not quite right, I discovered Michael Coyle's "Create a Custom Environment for Leopard's New Guest User" tutorial.

    I used Michael's tutorial to create friendlier Guest accounts on the six iMacs -- I set the desktop picture, changed the Safari home page to the library site, added iWork apps to the Dock, etc.

    As I was performing the setup on iMac #2, I decided I could bypass the tedious customization steps on the other iMacs:
    1. Copy the Guest account's Library folder to a flash drive.
    2. Copy that cloned Library folder into the User Template folder on the other four iMacs.
    What I didn't realize at the time was ...
    • Mac OS X assigns a random, hidden password to the Guest account.
    • My cloned Library folder included an empty Keychain, protected with the Guest account password from iMac #2.
    My quick testing of the new Guest accounts went fine. But as soon as library users started visiting password-protected sites, Safari would try using the Keychain and fail because it had the wrong password:

    Safari wants to use the "login" keychain.
    Please enter the keychain password.​

    It takes two clicks on "Cancel" to dismiss that dialog window.

    Once I learned about the random Guest password, the fix was easy:

    Delete the "User Template/English.lproj/Library/Keychains/" folder.​

    -- Ward
  6. LPZ
    macrumors 65816

    Jul 11, 2006
    Open Keychain Access. From the Edit menu, choose Change Setting for Keychain "login"

    Is either box checked?
  7. macrumors 68000


    Mar 28, 2006
    West Plains, MO USA Earth
    Thank you ... that should do it...:D

Share This Page