Another Wii Wi-fi question

Discussion in 'Games' started by AppleinJapan, Dec 4, 2006.

  1. AppleinJapan macrumors regular

    Apr 10, 2005
    Ok so i got these instructions to connect the wii to the mac....

    I thought I'd chime in as I just got my Wii connected to the net with Internet Sharing coming from the AirPort card in my mac pro.

    1. I had to enter the full HEX password. I actually used the WEP hex calculator page that gloss linked above, entered a 13 character password, and entered the HEX string into my Wii settings.

    That worked, it could connect to the wireless signal but not to the internet. So I went and...

    2. followed the same steps for setting up the DS with shared wireless and it connected perfectly.

    I turned off the OS X firewall just in case (as I remember the DS had problems with it) but later I'll try it with the firewall on. I also set the Airport to channel 1, as Nintendo's support site mentioned using channels 1 or 11 with the 52030 error code, which is what I was getting at first (incidentally, that error code also refers to a DHCP problem, which is exactly what that MacOSXHints article fixes).

    and Im having trouble with this part

    "Open and type ifconfig en1. In the output...
    • Look for: inet netmask ...
    • Take note the IP Address (the x's) associated with the first inet (mine was; yours may be different).
    • Type dig. Near the bottom of this output will be SERVER: followed by an IP address. This will be the DNS server you will use for your DS."

    I go to terminal and type in ifconfig en1 but inet xxx. etc etc doesnt come up at all.......i get

    ether 00:17:f2:98:79:3a
    media: autoselect (<unknown type>) status: inactive
    supported media: autoselect"

    so the instructions state: "IP Address: Take the first IP Address you obtained earlier, and make the last digit bigger. i.e., mine could be"

    Im not sure how to find netmark etc etc this IP address - when I type dig - I get the DNS server but not the IP address...

    Thanks for helping
  2. apfhex macrumors 68030


    Aug 8, 2006
    Northern California
    I was the one who posted those instructions, with a link to the MacOSXHints article.

    Instead of en1, you have to use whichever number is for your Airport card, i.e. mine is en2. You can find this in System Profiler under Network.

    Make sure you also have Internet Sharing already enabled, too.
  3. AppleinJapan thread starter macrumors regular

    Apr 10, 2005
    Thanks for you help mate ! cheers :D
  4. AppleinJapan thread starter macrumors regular

    Apr 10, 2005
    Still having problems...what am I doing wrong ???? Oh and sorry I forgot to mentain that my network is from modem - hub - Imac 24" the using Airport (wifi) to the wii
  5. apfhex macrumors 68030


    Aug 8, 2006
    Northern California
    No idea. Are you sure you entered the information correctly? It's easy to mess up.

    I think I had to enter something in the Secondary DNS Server field (using same numbers as the Primary DNS) to get it to connect properly, not sure.

Share This Page