any one know excel?

Discussion in 'Mac Apps and Mac App Store' started by bokdol, Oct 12, 2004.

  1. bokdol macrumors 6502a


    Jul 23, 2002
    i am wondering if anyone can help with excel. i am trying to imput somenumbers but exel seems to auto correct itself. and exaple would be if iput in 12-3-03 it automatically thinks it is a date so it changes to 12/03/2003. is there a way to put in a number with out it auto formating (i checked help and it says to pu a 0 and a space before each number ie: 0 12-3-03 but i dont want that 0 there..
    thank you for any help you can give me..
  2. Flying Llama macrumors 6502a

    Flying Llama

    Aug 4, 2004
    Los Angeles
    try to check in preferences, im sure you can turn off auto-correct. hope that helps! :)
  3. nesbitt_a macrumors 6502

    Nov 1, 2003
    Cell formatting settings

    If you right-click/ctrl-click on the offending cell, and go to cell properties. There is a formatting tab in there, check what your data is being formatted as. More than likely excel is auto-formatting to a date in some format - just choose (or customise) whatever format you like, or set it to plain text and excel will stop messing with your content.

    Cheers, A.
  4. zelmo macrumors 603


    Jul 3, 2004
    Mac since 7.5
    You need to re-format the cell.
    Highlight the cell you are entering the data into (and any other cell you want to re-format), then click command+1 to bring up the formatting palette. Select "text" from the list. Choosing this option allows the data to appear exactly as typed.
  5. lenb macrumors member

    May 11, 2004
    Leicester, UK

    type '02-03-04 and this will allow your numbers in as written. The ' is important!

  6. AmigoMac macrumors 68020


    Aug 5, 2003
    grrr you got it first... ;)

    again, as before posted, the ' is one of the most important things in excel ...
  7. bokdol thread starter macrumors 6502a


    Jul 23, 2002

    thanks guys... i just wish it could have been simpler :confused:
  8. maxterpiece macrumors 6502a


    Mar 5, 2003
    The easiest thing to do is hit apple-a to select all, then hit apple-1 to format all cells. If you choose to format them as text then they will appear exactly as you type them. No apostrophe necessary. I think that's the simplest way.
  9. osprey76 macrumors 6502

    May 3, 2004
    Oklahoma City, OK
    Yeah, even so Excel will, at times, autoformat despite the declared text formatting. Which is rather aggravating. I have a file with various serial numbers. One of them is all numbers with about 14 digits total. When I enter the cell and hit return, Excel displays it in scientific notation. The cell still shows to be formatted as text and number is preserved in the edit box. I have not turned off any autoformatting via preferences, though (typically they are useful to me.)
  10. philldo macrumors newbie

    Mar 5, 2008
    Declarations dont' always stick in Excel

    My first fix was to try declaring the "text" format to my cells in Excel but that does not always work. Excel auto formated my numbers to dates. I also searched the preferences to turn off this autoformat. No luck.

    I was getting very agravated too until i found this thread and the tip to use "'". Thanks a bunch. You RAWK.

Share This Page