Any way to disable the auto dimming on the Intel iMac's?

Discussion in 'Mac Pro' started by DevilsRejection, Jul 1, 2006.

  1. DevilsRejection macrumors regular

    Joined:
    Apr 13, 2006
    #1
    If I'm idle for about 1-2 minutes my screen gets dim. I understand why this would happen on a notebook, but this is a desktop machine :mad:

    Anyway, is there some way to fix this?
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    On my G5 iMac the option is in the Energy Saver pane of System Preferences, under the Options title and listed as Automatically Reduce The Brightness Of The Display... Unchecking this should stop it dimming. :)
     
  3. DevilsRejection thread starter macrumors regular

    Joined:
    Apr 13, 2006
  4. dmw007 macrumors G4

    dmw007

    Joined:
    May 26, 2005
    Location:
    Working for MI-6
    #4
    That, and you might also want to adjust the length of time before your display goes to sleep.
     

    Attached Files:

  5. thegreatluke macrumors 6502a

    thegreatluke

    Joined:
    Dec 29, 2005
    Location:
    Earth
    #5
    He's talking about how the display dims slightly after a couple of minutes.

    It's annoying, yes. I'm sure it increased the longevity of the display though.

    I don't know how to change it... someone should make a hack that fixes it.
     
  6. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
  7. risc macrumors 68030

    risc

    Joined:
    Jul 23, 2004
    Location:
    Melbourne, Australia
    #7
    [​IMG]

    Just uncheck Automatically reduce the brightness of the display before display sleep (exactly as mad jew says above). You'll need to make sure you click Show Details on the "Energy Saver" options screen to get this option. It works as expected here.
     
  8. DevilsRejection thread starter macrumors regular

    Joined:
    Apr 13, 2006
  9. risc macrumors 68030

    risc

    Joined:
    Jul 23, 2004
    Location:
    Melbourne, Australia
    #9
    If it doesn't work as expected on your Mac you should report it as a bug then, since that is exactly what it is.
     
  10. DevilsRejection thread starter macrumors regular

    Joined:
    Apr 13, 2006
    #10
    see but i'm not the only one, you can look at the official mac forum and this problem is a plague
     
  11. unfaded macrumors 6502

    Joined:
    Dec 12, 2002
    Location:
    Seattle, WA
    #11
    Do you have a mouse connected to your computer? The plague was transferred through rodents.
     
  12. y0zza macrumors regular

    Joined:
    Mar 10, 2005
    #12
    Seems like a common problem on the Intel iMacs. One of the few I should add.

    The solution appears to be to tick the option to dim the screen, close System Preferences. Then open it up again and untick the option.

    The screen will stay bright until it sleeps, but the dimming will be back after the next system startup/reboot.
     
  13. DevilsRejection thread starter macrumors regular

    Joined:
    Apr 13, 2006
    #13
    hmmm trying that now, hope it works!

    edit: do you have the issue y0zza?
     
  14. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #14
    Tried that, it doesn't work.
     
  15. DevilsRejection thread starter macrumors regular

    Joined:
    Apr 13, 2006
    #15
    It works for me! Thanks y0zza!

    edit: has this bug been reported? how does one report a bug?
     
  16. DevilsRejection thread starter macrumors regular

    Joined:
    Apr 13, 2006
    #16
    Ok I clicked the lock in the energy saver menu so the settings can't be changed, then I rebooted, I will edit this post to see if my issues are fixed 100% or not.

    edit: DAMMIT guess the lock doesn't do anything! oh well, i have a partial answer atleast, i shouldn't reboot hehe

    edit: hmmm my lock was open when going to the energy saver menu, weird.
     
  17. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #17
    Hmm, I'll try it again in case one of the recent updates has "fixed" it.
     
  18. DevilsRejection thread starter macrumors regular

    Joined:
    Apr 13, 2006
    #18
    by "fixed" you mean you still have the issue?
     
  19. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #19
    On 10.4.4, toggling the option on then back off did not fix it. However, you just reported success so something may have changed since.
     
  20. DevilsRejection thread starter macrumors regular

    Joined:
    Apr 13, 2006
    #20
    yes but rebooting screwed it up again
     
  21. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
  22. DevilsRejection thread starter macrumors regular

    Joined:
    Apr 13, 2006
    #22
    can i too? how would one go about this?
     
  23. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #23
    If you do, it'll just get marked as a duplicate (I expect that mine will too, I certainly won't be the first to have reported it).

    You need to be a registered developer to get into the bug reporting system, since you don't know about it I suspect that you're not a developer :)
     
  24. DevilsRejection thread starter macrumors regular

    Joined:
    Apr 13, 2006
  25. aaron.lee2006 macrumors 65816

    aaron.lee2006

    Joined:
    Feb 23, 2006
    Location:
    Ontario, Canada
    #25
    Are you DevilsRejection as in Make Me Switch on youtube.com?
     

Share This Page