Anyone know where I can get an older version of iTunes?

Discussion in 'Mac Apps and Mac App Store' started by dopey220, Sep 12, 2006.

  1. dopey220 macrumors 6502


    Jul 19, 2006
    I just got an eMac with OS 10.2, and my iPod won't mount. I went to download the newest version of iTunes (7), but I can't because you need OS 10.3 or greater. Anyone know where I can get a slightly older version of iTunes? Or, more specifically, how to manually mount my iPod? I don't really want to sync it, I just want to copy some files onto it.
  2. TMA macrumors 6502a


    Jan 6, 2003

    "System Requirements
    — Mac OS X 10.2.8 or later
    — Mac OS X version 10.4.2 or later is recommended
    — Windows 2000 or XP"

    You may need to run software update on your eMac to make sure it's up to 10.2.8.

Share This Page