Anyway to stop an external HD from spinning down?

Discussion in 'Mac Basics and Help' started by Subiklim, Oct 13, 2006.

  1. Subiklim macrumors 6502

    Mar 31, 2006
    Manhattan, New York
    I have an external 300gb seagate firewire drive, and I like to keep it attached, and on at all times, as it holds my media files. The problem is, it's constantly spinning down (which I don't mind... I don't like HD failure), the problem is when I attempt certain actions (for instance, putting the computer to sleep (there are many more, I just can't name them all)), my computer has to wait for the ext. hard drive to spin up adding several seconds to whatever action I am attempting to do.

    So I guess my question is rather than stop the hard drive from spinning down, is there anything I can do to eradicate the time it takes for it to spin up again?
  2. zakatov macrumors 6502a


    Mar 8, 2005
    South Florida
    is the "put HD to sleep whenever possible" setting on in you Energy Saver prefpane?
  3. mrichmon macrumors 6502a

    Jun 17, 2003
    You cannot eradicate the time that it takes for the drive to spin up. The spin up time is the time during which the drive motor is spinning up the disk platters from 0 rpm to the operating rotational velocity. This delay is hardware limited. From the OS point of view, an instruction to spin up the drive is sent to the drive and the OS does nothing with the drive until a message from the hard drive indicates that the drive is fully operational.

    You can however control the time before drives in your system spin down. You need to install the "CHUD Performance Tools" which are an optional part of the Developer Tools installation. The utility to control the Hard Drive spin down time is called "". If you don't want or need Developer Tools then you can use Pacifist to extract from the Developer Tools install package.
  4. mosaicinteracti macrumors newbie

    Dec 3, 2010
  5. mr666 macrumors member

    Sep 14, 2009
    My external HDD does not spin down or "spin and whirr" and I have not installed "No Spin". I have set the Energy Saver to "Put the computer to sleep: NEVER" and no check for "Put the hard disks to sleep when possible". It sounded like the logical solution as I read it in Energy Saver, and it works. Maybe my external HDD is not as stubborn as yours.

Share This Page