Apache2 listen 80

Discussion in 'Web Design and Development' started by fall3n, Sep 25, 2006.

  1. fall3n macrumors 6502

    Joined:
    Aug 17, 2006
    #1
    Hey guys, I've been setting up my server this week in my new iMac 24" (yes, i know I didn't have to say that, but it's so beautiful I think it needs some recognition. haha). It's all running perfectly, but for some reason it won't let me set the listen to port 80. Right now it's on 8080, but I really want to change it as I hate having to enter :8080 after every virtualhost I'm developing on. I have personal web sharing off, actually I don't even have it on my system at all so it shouldn't be that. I'm not sure what is going on. Whenever I make it listen to 80 and restart the server, it says that i can't start apache because it can't listen to that port. Anyone have any insight?
     
  2. Doctor Q Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #2
    Are you logged in under a regular account? I haven't tested this theory, but it could be that you have to log in under an admin account to start Apache on port 80 because it's a "system port number".
     
  3. fall3n thread starter macrumors 6502

    Joined:
    Aug 17, 2006
    #3
    Yes I am the administrator, so I'm always logged in. Someone mentioned it might be a program that I have open. I'll test that out when I get home. Another said it might be the default Mac OS X server that's hogging it, but I don't even have web sharing installed. Nonetheless, maybe it got turned on earlier and never got turned off
     
  4. fall3n thread starter macrumors 6502

    Joined:
    Aug 17, 2006
    #4
    well, I've come to the conclusion that something IS using port 80 and not allowing apache2 to use it. I don't know what it is that is using it though, how can I find out what program is using it and not allowing apache to use it?
     

Share This Page