Apogee Duet (firewire) on 10.7 Lion

Discussion in 'Digital Audio' started by HoldernessMedia, Jul 12, 2011.

  1. HoldernessMedia, Jul 12, 2011
    Last edited: Mar 20, 2012

    macrumors regular

    HoldernessMedia

    Joined:
    Apr 17, 2011
    #1
    3 TEMPORARY WORKAROUNDS for 1st gen Apogee Duet and Lion 10.7

    **Lion is still considered unsupported by Apogee at this point, so if you upgrade to Lion before Apogee releases an official update to Maestro or the Duet installer software, please don't cry about it here. :)
    Just try one of the workarounds below until Apogee releases their official software updates.
    These workarounds are for those of us who just have to try all the new stuff, or those who updated unknowingly.


    Let me first state that Im not sure these work across the board, both solutions have worked for different users. kittyflipping's method seems to work on both new and old machines, so try this process first. If that doesn't work, try #2 and see if that will work for your machine.


    Here's the rundown.

    Problems/Symptoms:

    You have an original firewire Duet, and installed the latest Maestro/duet installer on your machine running Lion. The Duet initially would show up as an available core audio device in both Logic and system sounds, but would not play back audio.

    If you try to playback audio or adjust the volume, the Duet would keep disappearing and reappearing as an available core audio device in Logic, same happens if trying to play from iTunes, etc. System sounds would show the Duet appearing and reappearing as an available device, but still NO audio.
    Tried rebooting, no dice. Permissions repair, reinstall Maestro, etc. and still the same issues.


    **Workaround solution #1 **
    (From kittyflipping, also confirmed working by Smeeth123 and HoldernessMedia)

    1. Open activity monitor
    2. Make sure "all processes" is selected in the popup menu at the top of the window.
    3. Select DuetDaemon and force quit it. For me I've had to force quit it twice to actually kill it.

    The Duet should be working fine now. Try the volume knob on the Duet.


    *Additionally, even though the Duet volume knob works fine after this, and system preferences recognizes the Duet, for some reason the volume icon in the menu bar remains grayed out, and my volume up/down keys on MBP don't do anything. So for anyone trying this, be sure and try the duet's volume knob if your keys aren't working.


    Also, on this solution, user Nitrus submitted this, using the kill duetDaemon method in an applescript:




    **Workaround solution #2**

    From Macrumors user VoiceofReason: (verified also by user vtk)

    "I have read the fixes so far for the Apogee Duet under OSX Lion, e.g. killing off "duetDaemon", etc.

    Here's a new one. Disconnect the duet, run the official uninstaller, and let it reboot. Then plug-in the Duet and re-select it as output device. Now, the Duet seems to work just fine and no killing of processes is needed. Of course, you can't go in and run Maestro b/c it doesn't exist, but when I killed of duetDaemon before it was annoying, it still didn't allow me to use the keyboard volume control for the Duet, and I was getting crackling audio with another drive running off the same firewire port. With THIS method (uninstalling the software) it at least works and you get volume control back."






    **Workaround solution #3 (Original)**

    (From HoldernessMedia, also confirmed working for aguaplano).

    Try this, in THIS EXACT ORDER. Opening Maestro BEFORE trying to do anything with audio is absolutely crucial. This also assumes that you already have the latest Duet installer/Maestro software from Apogee's site installed on your computer. (Version 1.9.14 at the time of this posting.)

    1.) Reboot the computer.

    2.) Do not touch the duet, or try to adjust volume yet. Seriously, don't do it yet. If you do, you will need to reboot.

    3.) Open Maestro, click on the "identify unit" button. You will see the Duet's hardware meters go full into the red. Wait a second or so, then click the "identify unit" button again. The Duet's hardware meters should return to normal.

    4.) If need be, in Maestro unmute the Duet's outputs.

    5.) Try playing audio out of the Duet now. Try using it as normal in Logic, GarageBand, iTunes, whatever.



    Please, anyone who upgraded to Lion please report back here if this works for you, or if you find any further information!

    I hope this works for others, although I'm sure Apogee is already working hard to get it ready either before or shortly after Lion's release.
     
  2. macrumors newbie

    Joined:
    Jul 14, 2008
    #2
    I just tried this, and unfortunately it didn't work for me. On my machine I get audio but if I try to adjust the volume the unit resets. I found that if I kill Duet Daemon after I boot up, sometimes this will restore the ability to adjust the volume (when the unit resets, it goes back to the previous volume setting).
     
  3. macrumors newbie

    Joined:
    Jan 24, 2011
    #3
    Duet1

    I tried that also and had the same errors as before, so thats why I reverted back to Snow Leopard until they fix the driver issue. Apogee will not respond back to me either. I asked when will they have a fix for this but said its not supported at this time. Thats not good if you want to upgrade !!!!!!
     
  4. thread starter macrumors regular

    HoldernessMedia

    Joined:
    Apr 17, 2011
    #4
    What year/model machine are you using? I am not having any issues with the Duet on GM build of Lion. Aguaplano also has it working on his machine using this process, and the only common factor I can see is we are both on older 2008/2009 model MacBook pros. Im wondering if maybe this only works on specific FireWire chipsets.

    Also, can you try this.

    Unplug the duet completely from your computer.

    Go into system preferences and select "built in audio" for your system sounds input and output. Make sure the duet is not chosen for either.

    If you have any kind of startup application that would access the duet to play back audio, disable it for now.

    If anything tries to use the Duet before you open Maestro and click "identify" you will have to reboot and start again.

    Now power down the computer, plug the Duet back, and boot the computer.

    Repeat the process above.
     
  5. macrumors newbie

    Joined:
    Jul 14, 2008
    #5
    I'm on a MacBookPro8,3 17" i7 (latest model) running the GM. I did disable any startup items I knew would use audio (Skype, iChat, etc.) but I haven't tried setting the built-in audio as the default. I'll give this a try later and post back the results, but killing the duet daemon did the trick for me as far as getting the volume to work, so I'm fine with sticking with that for now.

    Luckily I am not working on any music projects at the moment, so it's not an urgent need for me to get this fixed, just an annoyance. I did get a response from Apogee and they said to check back when Lion was released to the public.
     
  6. thread starter macrumors regular

    HoldernessMedia

    Joined:
    Apr 17, 2011
    #6
    Thanks for the info. Interested to see the results after you set built in as default.
     
  7. macrumors newbie

    Joined:
    Jul 14, 2008
    #7
    I tried setting the built-in as default, rebooting, repeating the steps, then setting the duet back as default. Same thing as before -- freezes when I try to change the volume. Also, same as before, I killed the duetDaemon and the volume started working again. :confused:
     
  8. macrumors newbie

    Joined:
    Jul 8, 2011
    #8
    I'm happy to report that I have managed to solve this issue using kittyflipping's technique. Unless anyone knows some disadvantage to killing DuetDaemon. For me at least, the following steps cause the Duet to work completely normally:

    1. Open activity monitor
    2. Make sure "all processes" is selected in the popup menu at the top of the window.
    3. Select DuetDaemon and force quit it. For me I've had to force quit it twice to actually kill it.

    From there, everything appears to be working perfectly. In the few times I've tested this, it hasn't mattered if I run any audio beforehand or what the system audio settings are set to. Thanks kittyflipping!
     
  9. HoldernessMedia, Jul 12, 2011
    Last edited: Jul 12, 2011

    thread starter macrumors regular

    HoldernessMedia

    Joined:
    Apr 17, 2011
    #9
    Hmm...so this process doesn't seem to be working on newer machines maybe?
    But killing the duetDaemon does work consistently?

    *Edit - looks like your technique worked for Smeeth123 as well. Thanks!
     
  10. thread starter macrumors regular

    HoldernessMedia

    Joined:
    Apr 17, 2011
    #10
    Awesome :)
    Thanks Smeeth123. I'm going to add this to the notes so people can try both and hopefully one way or the other will work for their machines.
    Now I'm going to see if I can get my test machine NOT working, so I can try this. Sounds stupid I know, but I'm really curious as to whether this affects different machines/firewire chipsets differently.
     
  11. macrumors newbie

    Joined:
    Jul 14, 2008
    #11
    Sure, this works consistently for me:

    1) Reboot (you might not need to if you haven't had any 'freezes' yet
    2) Load Activity Monitor, find and select the duetDaemon process and push the 'Quit Process' button + Quit (or Force Quit if you have to)

    That's it! The process (for me) restarts immediately, but the volume control now works.
     
  12. thread starter macrumors regular

    HoldernessMedia

    Joined:
    Apr 17, 2011
    #12
    Nice. :) Added your info to the initial post as a 2nd workaround for people to try via Smeeth123's post.
    Going to go see if I can recreate the problem on machine, then fix it with this solution. I'll be back in a few.
     
  13. macrumors 6502a

    Joined:
    Oct 26, 2007
    Location:
    Sydney, Australia.
    #13
    If you just want the Duet for audio playback, you need not install the apogee software. Just plug it in and hold the volume knob down till the light stops blinking. Sound preferences should pick it up automatically, otherwise choose it manually. It shouldn't be any different from using any other USB DAC.
     
  14. thread starter macrumors regular

    HoldernessMedia

    Joined:
    Apr 17, 2011
    #14
    Good to know, thanks!
    This has me wondering now, Smeeth and kittyflipping, are you able to use the Duet 100% normally? Recording and playing back audio?
     
  15. HoldernessMedia, Jul 12, 2011
    Last edited: Jul 12, 2011

    thread starter macrumors regular

    HoldernessMedia

    Joined:
    Apr 17, 2011
    #15
    Sweet. So I was able to get kittyflippings process to work on my machine as well! I am moving your process to the preferred method as it seems to be working for both new and old machines.

    In order for me to recreate the problem, I have to hotplug my Duet after the system is booted and running as it's been working without issue for awhile now. It works fine until I hotplug the Duet, then Duet drops and is not recognized by the system or by Maestro until I kill the duetDaemon.

    One quirky thing I noticed, even though the Duet volume knob works fine after this, and system preferences recognizes the Duet, for some reason the volume icon in the menu bar remains grayed out, and my volume up/down keys on MBP don't do anything. So for anyone trying this, be sure and try the duet's volume knob if your keys aren't working.
     
  16. jorgus, Jul 13, 2011
    Last edited: Jul 13, 2011

    macrumors newbie

    jorgus

    Joined:
    Jul 11, 2011
    #16
    The kill duetDaemon seems to work :). I have input too - not just output (someone wondered). Duet does not sync with system speaker volume (up in the top menubar) - and I don't have the floating transparent volume and info window Popup) when I do stuff on the Duet knob - but it works. So far.

    So - it seems like the first load of the daemon - or the order/sequence it comes together with other stuff that loads at OS start - becomes corrupt. Killing it so it can restart seems to produce a healthy daemon.

    Anyway - Apogee have to fix this. I want the info popup back :). And peace in mind - no ghost daemons and other evil stuff.

    This is a good place - I'm glad I signed up. Thanks.
     
  17. thread starter macrumors regular

    HoldernessMedia

    Joined:
    Apr 17, 2011
    #17
    This is cool, it seems killing the duetDaemon is working pretty well across the board. :)
    I get the same issues with not syncing with system speaker volume and no pop up, but only when I use the kill daemon technique.

    For whatever reason, my original process worked really well on my machine and everything on the Duet works normally, I have to hotplug it to intentionally cause issues. But after that, I still can just reboot and it behaves normally. Weird.

    I'm pretty hopeful Apogee will have an update soon. It may be as someone suggested in the other thread, maybe they can't release it yet due to NDA's and such.
    Now if Ableton will just push an update to Live soon, I'll be able to upgrade to Lion right away. I've got the itch, even after just playing around on the test machine, I go back to my main MBP and find myself doing some gestures and wondering "wtf? why isn't it working now?". Then I remember I'm on Snow Leopard, lol.
     
  18. jorgus, Jul 13, 2011
    Last edited: Jul 13, 2011

    macrumors newbie

    jorgus

    Joined:
    Jul 11, 2011
    #18
    My popup is suddenly back :). It comes and goes. The OSX speaker symbol (and volume adjuster) in top menu bar is greyed out, but that's ok. I never use it anyway.
     
  19. macrumors newbie

    Joined:
    Jan 24, 2011
    #19
    Apogee duet issues

    After reading all the post related to this I re-installed the Lion GM and tried out the "Kill Daemon" and what do you know it worked. I hope apogee will fix this soon so all of us don't have to go through these steps each and every time. Thanks people of the Music world for finding out the issue here, it's a life saver if your doing what I am :)
    :D
     
  20. thread starter macrumors regular

    HoldernessMedia

    Joined:
    Apr 17, 2011
    #20
    Glad the thread is helping people out. :)

    So, do you have to do the Kill Daemon trick every time you reboot?
    I'm still confused as to how/why my original process worked on my machine to the point of basically "curing" it. I don't have to do any tricks, works after reboots, behaves as normal now with the exception of hotplugging.
     
  21. thread starter macrumors regular

    HoldernessMedia

    Joined:
    Apr 17, 2011
    #21
    Glad the thread is helping people out. :)

    So, do you have to do the Kill Daemon trick every time you reboot?
    I'm still confused as to how/why my original process worked on mine to the point of basically "curing" it. I don't have to do any tricks, works after reboots, behaves as normal now with the exception of hotplugging.
     
  22. macrumors member

    Joined:
    Nov 20, 2009
    #22
    Run DuetPopup once, and make sure it's also in your Login items.
    DuetPopup can be found here: System/Library/Extensions/DuetPlugIn.bundle/Contents
     
  23. macrumors member

    Joined:
    Aug 20, 2010
    #23
    Can you expand on that a little? Are you saying to run DuetPopup in addition to the following AppleScript Editor solution?

    Just so I'm clear... let's say that my password is hotcoffee (it obviously isn't, but MMmmmmm, I'm drinking a delicious cup right now). Would I cut/paste EXACTY this into Applescript Editor?:

    Thanks for the info! I found this thread by doing a google search for "Apogee Duet" +Lion. I'm dying to upgrade as soon as possible and am checking to see what works and what I need to watch out for.
     
  24. macrumors newbie

    jorgus

    Joined:
    Jul 11, 2011
    #24
    Info:

    If you daisy chain FW800 with Duet last in the chain (Duet is FW400) - or have a FW800 hub - the speed from FW disks goes down 40-45% (to around 400 Mb/s.) after a while. Forcequitting/restarting duetDaemon brings up the speed again - for some time. This is new for Lion - did not happen in Snow Leopard. In Snow Leopard the speed was stabile around 6-700 Mb/s (thats what to expect from FW800 disks).

    Yes, I'm in desperate need for a new Lion driver update from Apogee. :-D. This is not good. This is bad. Apogee! Listen!
     
  25. macrumors member

    Joined:
    Nov 20, 2009
    #25
    do shell script "killall duetDaemon" password hotcoffee with administrator privileges

    this would be correct.
    hide it somewhere... and add it into your login items.

    If you're not seeing your Volume popup, make sure that it is listed in your Login items. If it is not, you can add it manually, or you can just reinstall the duet package.

    If it is... run it once manually, and reboot.

    Now everything should be working 100%!
     

Share This Page