app publish from 10.6.8 possible ?

Discussion in 'App Store Business, Legal and Marketing' started by chhoda, Oct 28, 2013.

  1. macrumors 6502

    Joined:
    Oct 25, 2008
    #1
    hi all,

    publishing iphone app to app store is no more possible from 10.6.8 and xcode 4.2 ? my app gets rejected after successful submit. I need to get an confirmation so that i can plan if i need to migrate to 10.8.*

    regards
     
  2. macrumors 604

    ArtOfWarfare

    Joined:
    Nov 26, 2007
    #2
    Why not upgrade to Mavericks? It's free to you and better than Lion/Mountain Lion.
     
  3. macrumors 68000

    Joined:
    Jan 28, 2003
    Location:
    Less lost in L.A.
    #3
    You need to describe if a reviewer is rejecting or some later part of the automated process.

    If you are talking about 10.8.*, then as ArtOfWarfare mentioned, you should be considering the upgrade to 10.9.
     
  4. thread starter macrumors 6502

    Joined:
    Oct 25, 2008
    #4
    thanks, it is automatically rejected, and it says ios 5 resolution image is not available, whereas i did provide an ios5 image.

    i am still in 10.6.8 not in 10.8

    still, maverick is free for 10.6.8 ?
     
  5. macrumors 603

    Joined:
    Jul 29, 2003
    Location:
    Silicon Valley
    #5
    iPhone 5 4" display support requires at least iOS 6.0, which requires at least Xcode 4.5 to build. Not sure which OS X runs Xcode 4.5.
     
  6. macrumors 65816

    Joined:
    May 1, 2010
    Location:
    California
    #6
    My understanding is that Mavericks is just plain and simply free. That would mean you don't need anything to upgrade from. You could buy ANY hardware that supports it and install it.

    I don't know if it's an 'upgrade' in terms for requiring a certain prior version of OSX.

    Some OSs use 'Upgrade' vs 'Full' versions, this should be in the Mavericks requirements documentation.

    I've heard that the latest Xcode requires Mavericks... that's why I'm working on moving from ML to Mavericks.
     
  7. Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #7
    According to Apple, Xcode 5 requires OS X 10.8.4 (i.e. Mountain Lion).
     

Share This Page