App was not installed on the iPhone because an unknown error occured.0xE8008016

Discussion in 'iPhone Tips, Help and Troubleshooting' started by kalariyaamit, Jul 2, 2009.

  1. macrumors newbie

    kalariyaamit

    Joined:
    Sep 18, 2008
    Location:
    Ahmedabad, Gujrat - India
    #1
    I posted this solution on another thread -- copied here for you:

    SOLVED.

    First, look at your ad-hoc provisioning file in text edit (just view it, don't overwrite it!)

    If it does NOT contain a line that says "<key>get-task-allow</key>" then you need to go to the program portal and get a NEW ad-hoc provisioning profile. There is a workaround where you can use the provisioning profile without this key, but Apple apparently has added this key to the ad-hoc provisions, and you might as well have the latest.

    However, that is not the final fix.

    The next thing you have to do is add a new file to the root of your project ... file, new file, iphone, code signing, entitlements. Call it "dist.plist" ...

    Open that file, and it will say "get-task-allow" with a checkmark for "true" -- this needs to be FALSE. Uncheck the checkbox, or if in text mode, type in "false"

    OK, almost there!!!

    Open the target build info window and where it says "Code Signing Entitlements" add "dist.plist"

    CLEAN THE BUILD

    BUILD AND GO

    ENJOY. :)

    Amit Kalariya.
    Virtueinfo - Ahmedabad.
     
  2. macrumors member

    Joined:
    Jun 1, 2009
    #2
    I had the same error and this post solve to me!!

    Thanks!!!:D:D:D
     
  3. macrumors newbie

    Joined:
    Aug 8, 2009
    #3
    Thank you! Setting get-task-allow to false solved my problem.
     
  4. macrumors newbie

    Joined:
    Sep 12, 2009
    #4
    help ?

    what do you mean ad-hoc provisioning file in text edit where is that in the iphone ?
     

Share This Page