Apple Mail keeps asking for password

Discussion in 'Mac Applications and Mac App Store' started by Mary H, Aug 28, 2010.

  1. macrumors regular

    Joined:
    Oct 11, 2007
    Location:
    Canada
    #1
    Hi,

    I have a MacBook Pro with SnowLeopard and an iMac recently upgraded to Snow Leopard. I am having the same problem with both Apple Mail accounts. When mail opens it asks for my password for my accounts - sometimes just one but often all three accounts. It doesn't matter if I request it being saved in the keychain, it still keeps requesting it.

    Can I do anything to change this?

    Thanks, Mary
     
  2. LPZ
    macrumors 65816

    Joined:
    Jul 11, 2006
    #2
    Open Keychain Access in your Utilities folder. In the Keychains panel click on login (is this keychain unlocked?) and in the Category panel select Passwords. Do you see an entry (or entries) for the mail server(s) you use? If so, double click on each such entry and check the Show password box to see if the stored passwords are correct.

    Just checking that the passwords are already correctly stored in your keychain.
     
  3. thread starter macrumors regular

    Joined:
    Oct 11, 2007
    Location:
    Canada
    #3
    Yes, I checked and they are correct.
     
  4. LPZ
    macrumors 65816

    Joined:
    Jul 11, 2006
    #4
    And I assume your login keychain wasn't locked ...

    In any case, you might try any/all of these:

    1) Run Keychain First Aid by pressing option-command-a in Keychain Access. Verify, and repair if needed.

    2) Delete those mail-server-related items from your login keychain. Restart Mail and enter them anew when requested; check the Remember in keychain box too.

    3) Check/correct the info in Mail-->Preferences-->Accounts. You can delete and retype the password here, and after you click to close the window, you'll be asked to save the changes you made.
     
  5. macrumors 603

    Joined:
    Feb 20, 2009
    #5
    From LPZ
    "2) Delete those mail-server-related items from your login keychain. Restart Mail and enter them anew when requested; check the Remember in keychain box too."

    This is what worked for me.

    I'm _guessing_ that there is some "crossed connection" between the Keychain application and Mail.app that is causing the problem. I'll guess again and speculate that the problem is that for some reason, certain normally-hidden bits of data (quite possibly "port-related" or "timeout-related") aren't being properly stored within a user's keychain.

    This can become quite a problem when updating to Snow Leopard from Leopard.

    The solution is to quit Mail and open Keychain Access, enter the administrative password and then open your keychain (to the point where you can delete password "keys").
    Then, delete ALL the mail-related passwords - ALL of them. These will have the letters "POP" in them for a "pop" mail account. If you're using an IMAP mail server, not sure what that will say. But it's relatively easy to ascertain which saved "keys" relate to your mail.
    Again, delete ALL of them from the keychain. You don't want any "traces left behind" that could foul things up.

    Now, quit Keychain Access and reopen Mail.app.

    First, test your capability to send mail. I would suggest you compose an email _to yourself_. You will be asked for a password (of course, since you deleted all your stored Mail.app passwords). Enter it, and (as LPZ said) click the "remember" checkbox for the keychain.

    If the mail gets sent ok, now check for incoming mail (this is why you sent email to yourself). Again, you will be asked for a password, and enter it and make sure it's saved in the keychain.

    Hopefully, this will get things going again.
     
  6. macrumors regular

    Joined:
    Mar 26, 2008
    #6
    After 3 days of issues with this problem and extensive research at many different forum threads. This solution worked for me as well. Wanted to bump up so others can be aware.

    As said before. The key is to close mail app 1st and then delete mail acct from keychain through steps followed above.
     
  7. macrumors newbie

    Joined:
    Apr 20, 2012
    #7
    Worked wonders for me!

    This is easier than messing with keychain

    Try deleting the apple mail plist file in library preferences and restarting Mail
    (Just move the file to desktop in case you want it back)
    Restarting Mail will create the new file for you

    Please post if it works for you
     
  8. macrumors newbie

    Joined:
    Mar 21, 2013
    #8
    This works well

    After trying all sorts of other 'solutions' from other sites, this worked- thank you!
     
  9. macrumors newbie

    Joined:
    Feb 15, 2012
    #9
    Where is this located?
     
  10. LPZ
    macrumors 65816

    Joined:
    Jul 11, 2006
    #10
    In Finder's Go menu, choose Go to Folder. In the box that appears, enter

    ~/Library/Preferences/

    Quit Mail. seth77's suggestion is then to move the file named

    com.apple.mail.plist

    to your Desktop and restart Mail.
     

Share This Page