Apple Mail won't send mail

Discussion in 'Mac Applications and Mac App Store' started by GFLPraxis, Apr 28, 2007.

  1. macrumors 604

    GFLPraxis

    Joined:
    Mar 17, 2004
    #1
    I'm working on my mom's MBP. She's got four mailboxes; one .Mac, two Comcast, and one with 1and1. All four can receive mail, none of them can send.

    Any troubleshooting suggestions?
     
  2. macrumors member

    Joined:
    Apr 18, 2007
    Location:
    Winnipeg, Manitoba, Canada
    #2
    I had this sort of problem when I first got my mac. I went back and forth with Shaw (isp) trying to figure it out, but couldn't really get anywhere. I finally just started playing with it, and later found out I had to turn Authentication off. I'm not sure if this is the same problem, but it sounds similar.
     
  3. macrumors newbie

    Joined:
    Mar 6, 2007
    #3
    I would first make sure no settings have been changed in Mail>Preferences. If nothing has been changed most of the time it is still a settings issue, I would check your outgoing server port for each account that isn't sending(you do this by going into Mail>Preferences then click on the accounts tab, then the account information tab, and there should be a server settings button on the bottom of the page) by default the port is set to 25, you can change that number to 587 and see if mail sends after that.

    If you are still having trouble here is a general article for being unable to send email: http://docs.info.apple.com/article.html?path=Mail/2.0/en/ml1041.html

    And also any error messages you are getting would be helpful as well.
     
  4. macrumors G4

    Joined:
    Jul 17, 2002
    Location:
    USA
    #4
    You are leaving out some very important information. However, I bet dollars to donuts that you are trying to use your Mom's computer on a different domain than the one for which her SMTP server is setup. An SMTP server is the outgoing mail server. Most ISPs don't allow access to outside SMTP servers. This is to reduce the SPAM that originates on their domains. When traveling, you usually have to use your ISP's webmail client rather than POP3/IMAP clients like Mail.
     
  5. thread starter macrumors 604

    GFLPraxis

    Joined:
    Mar 17, 2004
    #5
    Then why was it working last week? All four?
     
  6. thread starter macrumors 604

    GFLPraxis

    Joined:
    Mar 17, 2004
    #6
    Changing them all to port 587 fixed both Comcast accounts. Re-entering the .Mac details fixed .Mac. The 1and1 username and password were completely incorrect (m3998-something-something was the username, where the correct username should be the email), but that username is what has been working for the last year just fine.

    Don't ask me why they all broke at once; everything worked over port 25 just great last week!

    Thanks for the help!
     
  7. macrumors newbie

    Joined:
    Jul 20, 2010
    #7
    Mac does a bad job of auto finding the right ports

    So if your SMTP server requires SSL then manually set the port # to 465. If it doesn't need SSL then set it to 587 because generally port 25 is blocked quite often (lame ISP's mainly).

    I had the same issue and manually set the port to 465 with SSL and it just worked like a charm. Not sure why Mail doesn't actually try all the ports...:confused:
     
  8. macrumors newbie

    Joined:
    Apr 17, 2011
    #8
    still can't send mail

    Connection Doctor says my SMTP is ok, but MacMail still won't send mail from my Earthlink account. I tried changing ports, but that didn't work. I tried SSL, again no luck. I'm trying to send from my Earthlink address, but the error message says that I'm sending from my MobileMe address...even though the message says From: ix.netcom.com which is my Earthlink address...oh and it's smtpauth@earthlink.net - since I've turned off Authentication, I tried to leave out the auth, but no luck and if I keep Authentication, it asks for a password and rejects my password...any help would be much appreciated...thanks in advance, Ellen
     
  9. macrumors G4

    Joined:
    Jul 17, 2002
    Location:
    USA
    #9
    Two things:
    • Try Port 587.
    • Use the proper password.
     

Share This Page