Apple Releases MacBook Air Flash Storage Firmware Update 1.0

Discussion in 'Mac Blog Discussion' started by MacRumors, May 16, 2013.

  1. macrumors bot

    MacRumors

    #1
    [​IMG]


    Apple today released MacBook Air Flash Storage Firmware Update 1.0, an update for Mid-2012 MacBook Air models to address an issue with recovering from crashes.
    [​IMG]
    Flash storage module from mid-2012 MacBook Air (Source: iFixit)
    The update is 1.69 MB and requires OS X 10.7.5 or OS X 10.8.3.

    Article Link: Apple Releases MacBook Air Flash Storage Firmware Update 1.0
     
  2. macrumors newbie

    #2
    Not Needed????

    I have a mid 2012 13" Macbook Air, I ran software update but it didn't find any update. So i downloaded it direct off Apple website and on opening it said this computer doesn't require this update. Just a bit puzzled about it. Anyone else finding this?


    Picard323
     
  3. macrumors member

    #3
    I just ran the update and only received the new iTunes
     
  4. macrumors regular

    #4
    Shows up here. Using 10.8.4 build 12E47
     
  5. macrumors newbie

    #5
    The MAS showed the update was available. I installed it, it rebooted, did it's thing, but it keeps showing up in MAS as an available update. Downloading the manual update now to see if that one will stick.
     
  6. macrumors newbie

    #6
    Still not showing up for me. All I got was the iTunes update.
     
  7. macrumors 6502a

    blackburn

    #7
    Most likely there are different ssd models. And some don't require the update.
     
  8. Weaselboy, May 16, 2013
    Last edited: May 16, 2013

    macrumors demi-god

    Weaselboy

    #8
    Just showed up for me on my 2012 13" MBA (with the Toshiba SSD).
     
  9. macrumors newbie

    #9
    Manual update said it requires 10.7 (I'm on 10.8.3) and wouldn't install. So there's obviously something wrong with this update. I tried installing the update from the MAS again, but this time I manually shut down and let it install. Still showing up in the MAS. Oh well.
     
  10. macrumors 68000

    #10
    showed up in the MAS along with the itunes update about an hour ago for me. Installed with no problem's on my 2012 11" MBA
     
  11. Weaselboy, May 16, 2013
    Last edited: May 16, 2013

    macrumors demi-god

    Weaselboy

    #11
    Same here on 2012 13" MBA with 10.8.3. It goes through the update and reboots instead of shutting down like the instructions explain. Tried both manually and through the app store.

    I wonder if having Filevault on is causing a problem. I'm decrypting FV2 now to test this theory. Do you have FV2 on by any chance.

    Edit: Yep, that was it. I turned off FV2 and waited for it to unencrypt, then applied the update and it worked just fine. You can see the new SSD firmware version TPVABBF0 in sys info.
     
  12. macrumors 6502

    #12
    Chrome feels snappier.
    Is that a bug?
     
  13. dyn
    macrumors 68000

    #13
    Apple sources the SSDs from 3 manufacturers (Toshiba and Samsung being 2 of them). This may very well be a firmware update for SSDs from one of those manufacturers. This would explain why manually downloading and installing results in the "this update isn't required" messages some here are getting.
     
  14. macrumors demi-god

    Weaselboy

    #14
    That could be. Mine with the Toshiba SSD took the update.
     
  15. dyn
    macrumors 68000

    #15
    Mine is Samsung and I didn't get the update (yet?).
     
  16. macrumors 6502

    #16
    My Samsung 256 GB SSD didn't need the update, maybe it's for Toshiba SSD only.
     
  17. macrumors regular

    #17
    Last thing I need is an update...
     
  18. macrumors 68040

    ValSalva

    #18
    I think this is exactly right.
     
  19. macrumors member

    #19
    It'll keep popping up until it's plugged into a power source. Same thing happened last week with the Thunderbolt Firmware Update.

    Good luck!


     
  20. macrumors member

    #20
    Bahahahahaha
     
  21. macrumors newbie

    #21
    Yup, that did it! Thanks for the heads up.
     
  22. macrumors 65816

    Simplicated

    #22
    Because this is for Apple notebooks. :D:D
     
  23. macrumors 6502a

    MacHiavelli

    #23
    Has anyone managed to get this to install? I have tried through MAS and the direct download. Each time the install appears to go well, but on reboot the update reappears in the MAS saying it needs to be installed. I have tried it with FV2 on and off. No difference.
     
  24. macrumors demi-god

    Weaselboy

    #24
    Both shafnitz (a couple posts up) and I got it to install by turning off FV2. Did you wait for FV2 to completely unencrypt the drive before trying the install?
     
  25. macrumors 68040

    #25
    If you can boot from an external, unencrypted drive, it'll install from there. I did this with mine rather than decrypt and re-encrypt.
     

Share This Page