1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Apple Remote Desktop In Lion (Doesn't Work)

Discussion in 'Mac OS X Lion (10.7)' started by rmbrown09, Jun 2, 2011.

  1. macrumors 6502a

    rmbrown09

    #1
    Is there a known workaround??

    [​IMG]
     
  2. macrumors 68030

    #2
  3. macrumors newbie

    macwinman

    #3
    Remote Desktop Admin in Lion

    Clarifying this problem, as I'm having it too.

    1. Do clean install of Lion.
    2. Attempt to install RDA 3.3 (the original version I have) -- cannot install, due to error message as seen in earlier post.
    3. Download RDA 3.5 from Apple's site.
    4. Attempt to install RDA 3.5 -- cannot install, because it's only an update, not a full installer, and says it can't find an earlier installation

    So I have an unlimited client license for RDA which I cannot install now. Does anyone either know a workaround for this or know how I can (legally) obtain a full RDA 3.5 installer?
     
  4. macrumors 6502

    #4
    Exact same problem here.
     
  5. macrumors newbie

    #5
    Same problem!

    Sad
     
  6. macrumors newbie

    #6
    I'm wondering the same thing.
     
  7. macrumors regular

    #7
    Well I have it running fine here under 10.7.
    I already had it installed under 10.6 before I updated, so I suppose the only workaround currently is to already have installed v3.3 under 10.6 and then apply 3.5 updater either in 10.6 or 10.7 (the 3.5 updater installs fine in 10.7).

    Not being able to install ARD from fresh via 10.7 is a real oversight by Apple and hopefully they'll bring out an updated installer soon.
     
  8. macrumors P6

    Intell

    #8
    You have to remember that Lion was designed as an upgrade. On my clean Lion install I've noticed a few things missing that where in my Lion upgrade install.
     
  9. macrumors newbie

    #9
    Such as? Were these core components?
     
  10. macrumors P6

    Intell

    #10
    Some of the default user pictures, all but the generic printer drivers, all but two screensavers, most of the default desktop wallpaper, some of the alert sounds. Simple silly things like that. My guess is that this stuff was removed from the Mac App Store version to make the download smaller. If its already on the users' hard drive and it hasn't changed from Snow Leopard to Lion, why replace it?
     
  11. macrumors newbie

    #11
    K those don't sound very core. I just finished setting up a clean Lion install and was going to bang my head against the wall if I had to reinstall SL to get back some components.
     
  12. macrumors P6

    Intell

    #12
    I haven't explored everything yet, but there may be some slightly more critical thing.
     
  13. macrumors newbie

    macwinman

    #13
    Remote Desktop admin install workaround

    I called Apple tech support today and did get a viable workaround. It worked for me, and it'll work for others as long as they have a spare Mac OS X 10.6 station they can use for a few minutes. As far as I know, this is the only current workaround.

    1. Install RDA 3.3 on a different Mac running OS X 10.6.
    2. Patch RDA up to 3.5 on that Mac (you don't have to launch RDA to do this -- either use Software Update or if you have the updaters downloaded, just run them one-by-one until you've patched RDA to the current 3.5 version).
    3. Copy the RDA applications from your 10.6 station to the 10.7 station.
    4. Launch RDA and continue your setup normally from this point on.
    5. Go back to the 10.6 station and delete the RDA app, since you don't need it there anymore.

    My RDA is up-and-running now!
     
  14. macrumors 68030

    #14
    If you already had remote desktop installed at any time, it will appear in your purchases tab on the app store...regardless of how you installed it, thru the app store or off a disk.

    You should be able to re-install the latest version there...or upgrade there.
     
  15. macrumors newbie

    #15
    Also, to clarify, if you have another machine that you've already upgraded to 10.7, you can use the airdrop feature as well (no cable required) to copy the app to the new machine. Otherwise, target mode may be your best bet. For something like an Air, however, Airdrop or a USB stick with the original app copied are really the main ways (unless you got the optical drive as well, in which case, original media is okay too).
     
  16. wiaggioe, Nov 6, 2011
    Last edited: Nov 6, 2011

    macrumors newbie

    #16
    Install ARD 3.3 > 3.5 in Lion

    Hi All

    The solution to this is posted in Apple support site, in 2 articles, that have to be followed one after the other.
    At least worked for me ...

    I had the logic board of my MBP replaced. After that ARD crashed, not even allowed me to enter the product serial nbr.
    My laptop is running Lion 10.7.2.


    I fully uninstaled ARD following these instructions
    http://support.apple.com/kb/HT2577

    Then reinstalled it following these other instructions
    http://support.apple.com/kb/TS4055

    Reinstalling it over the existing copy didn't work, so I had to remove and reinstall then entered serial number.

    When it worked, quitted, copied back the saved prefs file with my settings, restarted, and all came back to life.

    I hope this helps ...

    Cheers
    Esteban
     
  17. macrumors newbie

    #17
    ARD 3.3 Installer vs OS X 10.7 Lion

    Not sure if this will be of use to anyone, but if you try and install Remote Desktop 3.3 on Lion or Mountain Lion, it claims you need to be running Snow Leopard (OS X 10.6). Bummer.

    Rather than fork out to buy the latest version of ARD from the App Store, here's a work around:

    http://support.apple.com/kb/TS4055

    (the work around involves digging through the ARD 3.3 Installer right down to the actual Remote Desktop.app, copying it into /Applications and then running Software Update. Boom. Latest version of ARD.)
     

Share This Page