1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Apple TV Does Not Recognize AppleID Account

Discussion in 'Apple TV and Home Theater' started by UneElle, Sep 30, 2010.

  1. macrumors member

    Got my new AppleTV yesterday, unboxed it and set it up without problems. Easily connected to my wireless network and was able to view movie and TV previews on iTunes. But when I tried to set up Home Sharing I ran into a problem. When I got to the "enter your Apple ID and password" screens, I repeatedly got an error message indicating "Unable To Sign In" because either my Apple ID or my password was not recognized. Eventually I spent over 90 minutes on the phone with Apple Support without success. Still cannot sign in. Support tech suggested I try connecting AppleTV to my wireless router using an ethernet cable to see if the problem resides in my router's security. I've got to run out and get an ethernet cable, but in the meantime, does anyone here have any suggestions or help they might offer me? Everything here runs wirelessly without problems (2 iPhones, iPad, MacBook Pro, and a Canon wireless printer). Thanks in advance!
  2. macrumors 68020

    The instruction manual mentioned something about certain characters in Wifi passwords may cause problems. I would check that first.
  3. macrumors member

    Already tried that. No "odd" characters in my wireless PW. :(
  4. macrumors member

    Still no luck. Tried connecting AppleTV to router using ethernet and it still doesn't recognize AppleID and/or password so they don't think it's a problem with router firewall. Spoke again with Apple Support and it's now been bumped up to the engineers. So, essentially I cannot use it till they get back to me Monday or Tuesday with more suggestions.

    Anyone else here experiencing this problem? :-(
  5. macrumors 68020

    I could not get on my network - however I was using all caps and the network is case sensitive.

    Dropped down to the small letters line and worked like a charm.

    While the non capital line was right in front of me I did not see it as I was looking for a shift key or whatever :rolleyes:

    BTW - the navigation is horrible and this cheap little remote will not last long - no way will it be durable enough.
  6. macrumors 68020

    Do you have an iPhone, iPod Touch, or iPad? If so you need to download Apple's free Remote app. The experience is better than using the little aluminum remote. Inputting text and navigating is much easier.
  7. macrumors 68020

    Sure do - will download tonight.

    That said, I hope someone comes up with an inexpensive 3d party remote.
  8. macrumors 68020

    Are you running a closed network (wherein you have to enter the device Mac address in the Airport Utility) before you can connect?
  9. macrumors member

    No, I didn't need to do that. All I had to do was enter my network password initially then I was able to connect (wirelessly) easily when I first installed the unit. Then I was able to view previews (movie and TV) as well as listen to internet radio. The problem(s) began when I tried to sign in to my Apple (iTunes) account. The Apple Support guy even had me try creating an entirely new account on iTunes on my MacBook then try to use that account on my AppleTV without success. Connecting using an ethernet cable didn't work either. And the problem isn't that I'm not using the proper (upper or lower) case characters. It's really baffling, and it essentially renders my unit useless until it's resolved.
  10. macrumors newbie

    FWIW, I was having a similar problem. My Apple TV was on the network (wired), had an IP, and was able to browse content, but was refusing to log into my iTunes account.

    I did the TCP/IP network test in the Network menu, and for whatever reason, I was then able to log into my account.
  11. macrumors member

    Thanks so much for the info. I'll give it a try!
  12. macrumors 6502a

    Others with similar issue are reporting to reinstall iTunes and it will work.
  13. macrumors member

    I'm sorry, don't mean to sound totally stupid, but do you mean uninstalling and reinstalling iTunes from one's computer? If so, and again I'm sorry to sound stupid here, but if you uninstall iTunes from your computer, what happens to all your music and other content?
  14. macrumors newbie

    apple tv and apple id

    i too had the same problem with apple tv not recognising my apple id over and over again. what i did do finally was to ensure that home sharing was switch on with iTunes first on my mac - then i reset the apple tv box to factory settings and started again. It all worked perfectly then. Hope this works for you too.
  15. macrumors member

    Thanks for the response. Since my first posts, I've tried damned near everything. I've been on the phone with Apple support at least 3 times, for almost 3 hours. I've been to the Apple store with my ATV and my MacBook, where, for the first and only time, I was able to log in with my AppleID. But when I got back home, again no go. Then I bought a new router. Still no luck. I've reset my router and my cable modem (numerous times), and reset my ATV to factory settings at least 3 or 4 times in the process. I've spoken with my ISP and have forwarded all the ports that ATV uses ( 123, 80, 3689, 5353, 443, and 53 ) on my router. I've dismantled firewalls and encryption. And, in desperation, I tried, in effect, opening my router entirely. All without success. So, I'm left with one last gasp...Tuesday my cable provider is coming out and will test and replace my cable modem. If that doesn't work, I honestly don't know what else I can do. This is beyond frustrating.
  16. macrumors newbie

    Hey, I was having similar issues that you were experiencing. I changed my Apple ID password and had it contain a capital letter in it and a numerical number in it. Don't know how this solved my issue with it, but if you are still experiencing problems might as well give this a try.

    Good luck!

  17. macrumors member

    Right now, it appears as if the actual problem is with my ISP. They provide my internet service, my cable TV and my landline phone. We were able to ascertain that they (the ISP) have all their ports under number 1020 locked down pretty tight (with a few obvious exceptions such as port #80). And 4 of the 6 ports ATV2 utilizes are under #1020. <If anyone needs to know, according to Apple Support, ATV2 uses ports #123, 3689, 80, 443 and 53 TCP ports, and #5353 UDP port>. Higher level techs came out today with a modem configured strictly for "enterprise" internet service (essentially for business use, not residential) and when they hooked up that modem and I tried to log in, it worked instantly. I still cannot connect using my residential cable modem, but we're much closer to a resolution. The ISP is taking responsibility for the problem and is working with me to resolve it. Not just for me individually, but also for any of their customers who may purchase ATV2's in the future. Using me as a test case as it were. Tomorrow an even higher level technician is coming here to work to reconfigure my cable modem and make certain that all my router port forwarding settings are correct. Once they know exactly which ports they must open up at their end if a customer has an ATV2 and how routers must be set up, I'm hopeful I'll finally be able to start using my new "toy." I've got to say that, so far, I'm very impressed with the level of service I'm getting from my ISP. They seem genuinely interested in solving my problem and learning how to instruct other customers in the future. Keeping my fingers FIRMLY crossed!
  18. macrumors member

    SUCCESS!!! My ISP came back today after opening the ports that ATV2 uses at their end, especially #123, which seemed to be the one which was preventing my logging in. :)
  19. nvt
    macrumors newbie

    I want to add some data to what is a persistent problem based on my search of this board and others.....
    I had this as an intermittent problem where the Apple TV would not accept my Apple ID and password (which I know I entered correctly adn contained no odd characters)
    Lost of trouble shooting on wifi to no avail. I then hooked it up direct on a Cat5 port since I have the house wired. The same problems occurs so it has *nothing* to do with wifi.
    Additional research suggested it was a port issue - I don't have any port filtering or forwarding but the one thing you can do easily to expose a single IP address is set it as the DMZ. So I linked the AppleTV Mac ID to a single IP address and assigned this to the DMZ.
    Problem solved......
    Not sure I can explain this since there are no rules in my router to filter anything but hope this helps someone
  20. macrumors newbie

    Yet something else to try . . .

    This seems to be a really great repository for things to try, so I'll post my experience and how I got it to work. I'd been having the same issue: Apple TV gets great internet access (movie previews, internet radio, Netflix etc.) but refuses to login with my Apple ID. I had thrown countless hours at the problem as well. Quick background: I have AT&T U-verse, and they provided me with a DSL modem / router / WiFi all-in-one box. One ethernet port of that router is then wired (through my house) to an Apple Airport Extreme, that's set up as an access point. This way, I can get WiFi on the other side of my house. The Airport Extreme is also acting as a hub as well for a few wired devices. One of those wired devices is . . .(drum roll please) . .. my Apple TV. I had finally found this post (thank God) and un-blocked all the ports, which I can do on my AT&T U-verse router and still - no luck. It finally occured to me to bypass the Airport Extreme and used the WiFi directly from my AT&T Route, even though the signal was weak and it was on the other side of our house. I left all the ports still open for Apple - listed above in this discussion thread on the main AT&T router. It works now. It seems to me that the Airport Extreme was blocking access, even though the AT&T box was letting it through. I intend on closing back the ports and leaving the main house router in "factory setting" mode, to see if it still works. I don't know if there's a way to access the Airport Extreme, and turn off whatever security is blocking it too? It has an IP address, but since it wasn't the main DHCP server I don't know how to get to it's little configuration web page.
  21. macrumors newbie

    And some final testing for me revealed: Apple TV won't work downstream of an Airport Extreme in "bridge mode". Period. It works fine when connected directly to my main Internet connection. No fancy Port Forwarding required. RIP Steve Jobs. I hope your successors can keep it together.

Share This Page